Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
May 25, 2017 9:24:12 PM org.apache.spark.launcher.OutputRedirector redirect
INFO: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
This happens when Livy tried to connect to Hive Metastore and fails with above message.
The fix is to configure Zeppelin's Livy interpreter to run in yarn-cluster mode, instead of the default yarn-client mode. After you change any interpreter configuration, you will need to restart the interpreter.
Below works.
livy.spark.master
yarn-cluster
Starting HDP 2.6.x this configuration is changed OOB to yarn-cluster.