Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar

This is applicable in a Kerberos enabled HDP 2.5.x cluster with Zeppelin, Livy & Spark.

Post successful Kerberos setup, log in to Zeppelin and run Spark note, the note runs file.

But running simple sc.version from livy interpreter gives "Cannot start spark" in the Zeppelin UI.

In the Livy log at /var/log/livy/livy-livy-server.out you may find a message similar to the following.

INFO: 17/05/25 21:24:12 INFO metastore: Trying to connect to metastore with URI thrift://vinay-hdp25-2.field.hortonworks.com:9083

May 25, 2017 9:24:12 PM org.apache.spark.launcher.OutputRedirector redirect

INFO: 17/05/25 21:24:12 ERROR TSaslTransport: SASL negotiation failure

May 25, 2017 9:24:12 PM org.apache.spark.launcher.OutputRedirector redirect

INFO: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]

This happens when Livy tried to connect to Hive Metastore and fails with above message.

The fix is to configure Zeppelin's Livy interpreter to run in yarn-cluster mode, instead of the default yarn-client mode. After you change any interpreter configuration, you will need to restart the interpreter.

Below works.

livy.spark.masteryarn-cluster

Starting HDP 2.6.x this configuration is changed OOB to yarn-cluster.

2,235 Views
0 Kudos
Version history
Last update:
‎05-25-2017 09:46 PM
Updated by:
Contributors