Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
avatar
Rising Star

PROBLEM:

When installing RPM during HDP Upgrade on few nodes, the installation fails with the following error:

rpmdb: /var/lib/rpm/Packages: unexpected file format or type  
error: cannot open Packages index using db3 - Invalid argument (22)

ROOT CAUSE

This issue occurs when the RPM database is corrupt.

RESOLUTION

To resolve this issue, do the following:

  1. Take a backup of existing RPM database:
    mkdir /root/rpmdb.bak
    cp -rp /var/lib/rpm/__db* /root/rpmdb.bak/
  2. Remove the corrupted RPM database files:
    cd /var/lib/rpm
    rm -rf __db*
  3. Rebuild the RPM database:
    rpm --rebuilddb
1,138 Views
Version history
Last update:
‎09-16-2022 01:41 AM
Updated by:
Contributors