Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
Ranger Tagsync shows lots of KafkaException in log file, which causes disk space alert in Ambari. Also it used out all of the client port.
/var/log/ranger/tagsync/tagsync.log
10Nov 201611:46:43ERROR TagSynchronizer [main] - 262tag-source:atlas initialization failed withjavax.security.auth.login.LoginException: Could not login: the client is being asked fora password, but the Kafka client code does not currently support obtaining a password from the user. not availableto garner authentication information from the userkafka.common.KafkaException: fetching topic metadata fortopics [Set(ATLAS_ENTITIES)] from broker [ArrayBuffer(BrokerEndPoint(1001,host.domain,6667))] failedat kafka.client.ClientUtils$.fetchTopicMetadata(ClientUtils.scala:73)at kafka.client.ClientUtils$.fetchTopicMetadata(ClientUtils.scala:96)at kafka.consumer.ConsumerFetcherManager$LeaderFinderThread.doWork(ConsumerFetcherManager.scala:67)at kafka.utils.ShutdownableThread.run(ShutdownableThread.scala:63)Caused by: java.nio.channels.ClosedChannelExceptionat kafka.network.BlockingChannel.send(BlockingChannel.scala:122)at kafka.producer.SyncProducer.liftedTree1$1(SyncProducer.scala:82)at kafka.producer.SyncProducer.kafka$producer$SyncProducer$doSend(SyncProducer.scala:81)at kafka.producer.SyncProducer.send(SyncProducer.scala:126)at kafka.client.ClientUtils$.fetchTopicMetadata(ClientUtils.scala:59)... 3more
Background
The Atlas was installed after the HDP2.5.0 was kerberosed. Ambari2.4.1 doesn't create the kerberos principal for Ranger Tagsync, and distributed to the node. Could find the hint from Tagsync log: