Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
New Member

SYMPTOM: When you create an Oozie workflow which contains a SSH function, it can fail with an error of "Not able to perform operation [ssh -o PasswordAuthentication=no -o KbdInteractiveDevices=no -o StrictHostKeyChecking=no -o ConnectTimeout=20 root@localhost mkdir -p oozie-oozi/0000009-131023115150605-oozie-oozi-W/Ssh--ssh/ ] | ErrorStream: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password)."

 

ROOT CAUSE: Passwordless SSH must be setup correctly from oozie@server1 to $user@server2
For example: 

RESOLUTION: 
If an Oozie workflow contains an ssh command from server 1 to server 2 as root, then the passwordless SSH must be setup as the following:


oozie@server1 > root@server2

 


This article created by Hortonworks Support (Article: 000001722) on 2015-04-01 11:05
OS: Linux
Type: Configuration,Executing_Jobs
5,423 Views
Comments

Do you enter that line in the workflow itself to set up passwordless SSH?

Can someone please elaborate more on how to set up passwordless SSH or embed into workflow? Thank you.

Version history
Last update:
‎07-21-2016 03:01 PM
Updated by:
Contributors