Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
avatar
Super Guru

SYMPTOM: HDP upgrade failed on "Finalize". Tried setting the version manually using below command which was failing -

ambari-server set-current --cluster-name=<ClusterName> --version-display-name=HDP-2.5.3.0

ERROR: Please find error screenshot below -

11869-screen-shot-2017-01-30-at-63059-pm.png

ROOT CAUSE: There was issue with the last "request_id" which was run by Express upgrade process. you can check the last request_id from ambari DB from table name "host_role_command"

RESOLUTION:

1. Backup the ambari DB

2. Find the last "request_id" from table "host_role_command" and check the status of the request_id.

3. In my case the status was "Failed"

4. Modifying the status of the request_id from "FAILED" to "COMPLETED" and restart ambari server.

5. Try running the command again

ambari-server set-current --cluster-name=<ClusterName> --version-display-name=HDP-2.5.3.0

screen-shot-2017-01-30-at-63059-pm.png
1,373 Views
Version history
Last update:
‎09-16-2022 01:38 AM
Updated by:
Contributors