Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
When tried to
install SmartSense then it failed on Activity Analyzer installation which is
the first step of SmartSense installation.
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py", line 73, in _getattr_raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")resource_management.core.exceptions.Fail: Configuration parameter 'hadoop-env' was not found in configurations dictionary!
Similar error
occurs when trying to reinstall HST SERVER then it failed with similar message.
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py", line 73, in _getattr_raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")resource_management.core.exceptions.Fail: Configuration parameter 'namenode_host' was not found in configurations dictionary!
Reason:
SmartSense
components assumed that hdfs will always be available on each node.
Solution:
Upgrade to
SmartSense 1.3.1.
- Upgrading to SmartSense 1.3 (https://docs.hortonworks.com/HDPDocuments/SS1/SmartSense-1.3.0/bk_installation/content/upgrade_scenarios.html)
- Upgrading to SmartSense 1.4 (https://docs.hortonworks.com/HDPDocuments/SS1/SmartSense-1.4.0/bk_installation/content/upgrade_scenarios.html)