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Cloudera Employee

Symptoms:

Users may see an incorrect host domain name that may also include unexpected markers e.g. hadoopnode1.kjtijasdh.com , hadoopnode1.??kjtijasdh??.com

Diagnosis:

All data collected by HST Agents is anonymized via a process that uses a set of configurations along with anonymization rules to mask potentially sensitive data. The configurations include definitions for anonymization markers that are used to identify the start and end of a piece of data that has been anonymized via the rules. Certain anonymized content, such as host domain names, can later be deanonymized at the time of sending SmartSense recomendations so that the host domain is recognizable to the user. Typically the configured markers are unicode characters such as “¶” and “‡” which can can be incorrectly identified if the locale on the host running the HST Agent is not setup correctly which results in ?? as a default replacement.

Solution:

Making sure that you are using the same user that runs the HST agent on the problem host, display the locale setting with the following command:

locale –a

Look for the LANG setting; if LANG is not setup with a UTF8 variant then we must add an export statement setting LANG to the appropriate UTF8 encoding in the user's profile (same one that runs the HST Agent). The following is an example of this change for english/US:

export LANG=en_US.utf8

The language might change from English to something else based on your locale but it has to be UTF8. Repeat the same change on all impacted hosts in your cluster. Once the change has been completed and sourced, please capture another SmartSense bundle to get new recommendations with the corrected host domain.

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