Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
4. Now create the test schema again. This will throw below exceptions :
0: jdbc:phoenix:> create schema "test";
Error: ERROR 721 (42M04): Schema with given name already exists schemaName=test (state=42M04,code=721) org.apache.phoenix.schema.SchemaAlreadyExistsException: ERROR 721 (42M04): Schema with given name already exists schemaName=test
5. Now attempt to drop the test schema again:
0: jdbc:phoenix:> drop schema "test";Error: ERROR 722(43M05):Schema does not exists schemaName=test (state=43M05,code=722) org.apache.phoenix.schema.SchemaNotFoundException: ERROR 722(43M05):Schema does not exists schemaName=test
If you look in Hbase and list_namespace, you will see the test schema still exists.
ROOT CAUSE : This is a known issue discussed in Apache JIRA PHOENIX-3694
SOLUTION : Issue is fixed in Phoenix 4.10. For a backport hotfix , please log a case with HWX.