Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
PROBLEM : Customerscreate namespace and assign users "RX" permission , however users are not able to create tables in namespace and require "RWX" permission.
CREATE TABLE example_datapipe.table_test1 ( id BIGINT not null primary key); Error: org.apache.hadoop.hbase.security.AccessDeniedException: Insufficient permissions ([email protected], scope=SYSTEM:CATALOG, family=0:SALT_BUCKETS, params=[table=SYSTEM:CATALOG,family=0:SALT_BUCKETS],action=WRITE)
ROOT CAUSE : Yes this is an expected behavior. To create a Phoenix table, you MUST have the ability to create the HBase table and you MUST have the ability to write to the SYSTEM.CATALOG table.
WORKAROUND : If you do not want normal users to have write access on system.catalog, try one of the following alternatives :-
1) Let an admin manually create the Phoenix tables for the unprivileged users.
2) Temporarily grant them write access to the SYSTEM.CATALOG table and revoke later.