Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (2)
avatar
New Member

When running the YARN service check in a Resource Manager HA environment you see that the service check fails - all other functionality is working correctly (restart of services, running jobs etc)

When you run the service check you see:

stderr:   /var/lib/ambari-agent/data/errors-392.txt
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/scripts/service_check.py", line 159, in <module>
    ServiceCheck().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/YARN/2.1.0.2.0/package/scripts/service_check.py", line 130, in service_check
    info_app_url = params.scheme + "://" + rm_webapp_address + "/ws/v1/cluster/apps/" + application_name
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py", line 73, in __getattr__
    raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'yarn.resourcemanager.webapp.address.' was not found in configurations dictionary!

Notice the . at the end of the parameter - yarn.resourcemanager.webapp.address.

This is a result of having:

yarn.resourcemanager.ha.rm-ids set to rm1,rm2, (notice the comma at the end)

This leads to the scripts in ambari putting these values into an array for checking where {{rm_alias}} is set for rm1, rm2 and then a blank value.

To fix this issue you must remove the trailing , in the configuration value for this property.

After removing this and restarting YARN, the service check will pass

3,891 Views
0 Kudos
Comments

Well I have the same error but I don't see extra trailing ,. 

I see yarn.resourcemanager.ha.rm-ids set to rm1, rm2

Version history
Last update:
‎10-19-2016 06:16 PM
Updated by:
Contributors