Community Articles
Find and share helpful community-sourced technical articles
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (2)

Issue: When running hive shell in a docker you will be getting a message "mbind: Operation not permitted" printed on the console but the operations will pass.

.

Root Cause: mbind syscall is used for NUMA (non-uniform memory access) operations which is blocked by docker by default. But in hive opts there is an option which specifies '+UseNUMA'.

.

Resolution:

Go to Ambari -> Hive -> Configs -> Advanced

1) Remove '-XX:+UseNUMA' from 'hive.tez.java.opts'.

2) Remove '-XX:+UseNUMA' from hive-env template.

Hope this helps :)

1,775 Views
Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
1 of 1
Last update:
‎02-21-2018 09:01 AM
Updated by:
 
Contributors
Top Kudoed Authors