Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Community Articles

Find and share helpful community-sourced technical articles.
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!
Labels (1)
avatar
New Contributor

We have deployed the minor patch updating 7.1.9-1.cdh7.1.9.p1042.65851740 to 7.1.9-1.cdh7.1.9.p20000.79072338 and during the mandatory restarts, we saw Hive Metastore failing with the below error:

2026-07-23T00:18:33.533632426Z main ERROR Unable to locate appender "LOGFILE" for logger config "guru.springframework.blog.log4j2properties"
WARNING: Use "yarn jar" to launch YARN applications.
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p20000.79072338/jars/log4j-slf4j-impl-2.25.3.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/opt/cloudera/parcels/CDH-7.1.9-1.cdh7.1.9.p20000.79072338/jars/slf4j-reload4j-1.7.36.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory]
Exception in thread "main" java.lang.ExceptionInInitializerError
Caused by: org.apache.logging.log4j.core.config.ConfigurationException: No type attribute provided for component logger

Resolution

  1. To resolve this issue, do the following: 
    Go to Hive Metastore service > Configuration > Hive Metastore Server Logging Advanced Configuration Snippet (Safety Valve)
  2. Add the following property 
     loggers=Initiator,Cleaner,PerfLogger​

DISCLAIMER:  An external user contributed to this article. Cloudera may not verify that the steps may be applicable for all use cases and may be very specific to a particular distribution. Please follow with caution and at your own risk. If needed, raise a support case to get confirmation.

 

127 Views
0 Kudos