Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

AMBARI Infra SLR does not start the instance after: "no valid keystore" message

avatar
Explorer

Hello team,

 

I have tried to change the cluster certificates following the indications from the manual, plus internal company documents.

 

I am stucked when starting the cluster, as when I try to start the INFR Solr instance, it returns a "no valid keystore" message.

 

I have tried with the passwords that are configured in the config files for the service, and it works smoothly.

 

I have done manual comparisson to working environments and everything seems to be in order.

 

Any idea where to hit? Thanks in advance 🙂

1 ACCEPTED SOLUTION

avatar
Master Collaborator

@josr89 Can you please provide the exact error you are getting? 

Please check if you have the right set of permission on that file as well as the parent directory. 

 

Also there could be possibility you are facing the trust store related issue so the complete stack of the error will help me to identify the issue. 

View solution in original post

2 REPLIES 2

avatar
Master Collaborator

@josr89 Can you please provide the exact error you are getting? 

Please check if you have the right set of permission on that file as well as the parent directory. 

 

Also there could be possibility you are facing the trust store related issue so the complete stack of the error will help me to identify the issue. 

avatar
Explorer

Hi @Kartik_Agarwal !

 

I solved this a couple of weeks ago, but you are right with your comments:

 

In my case the file was having the right permission set, but the parent directory had not. So with the change of permissions to the parent directory, it worked fine.

 

Thanks for your support!