Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-06-2019 09:56 AM
Am trying to add a new host to a cloudera managed cluster using wizard ... but it keeps failing with message "/tmp/scm_prepare_node.fj3OyPGR
Connection reset "
and server logs shows ...
2019-03-06 19:37:18,074 INFO scm-web-300:com.cloudera.cmf.service.ServiceHandlerRegistry: Executing command GlobalHostInstall GlobalHostInstallCommandArgs{sshPort=22, userName=sw, password=REDACTED, passphrase=REDACTED, privateKey=REDACTED, parallelInstallCount=10, cmRepoUrl=null, gpgKeyCustomUrl=null, gpgKeyOverrideBundle=<none>, unlimitedJCE=true, javaInstallStrategy=NONE, agentUserMode=ROOT, cdhVersion=-1, cdhRelease=NONE>, cdhRepoUrl=null, buildCertCommand=, sslCertHostname=null, reqId=20, skipPackageInstall=false, skipCloudConfig=false, hosts=[hadoop.localdomain.38], existingHosts=[]}.
2019-03-06 19:37:18,074 INFO scm-web-300:com.cloudera.cmf.command.flow.CmdStep: Executing command work: Execute 1 steps in sequence
2019-03-06 19:37:18,074 INFO scm-web-300:com.cloudera.cmf.command.flow.CmdStep: Executing command work: Install on 1 hosts.
2019-03-06 19:37:18,074 INFO scm-web-300:com.cloudera.cmf.command.flow.CmdStep: Executing command work: Install on hadoop.localdomain.38.
2019-03-06 19:37:18,074 INFO scm-web-300:com.cloudera.server.cmf.node.NodeConfiguratorService: Adding password-based configurator for hadoop.localdomain.38
2019-03-06 19:37:18,075 INFO scm-web-300:com.cloudera.server.cmf.node.NodeConfiguratorService: Submitted configurator for hadoop.localdomain.38 with id 21
2019-03-06 19:37:18,078 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfiguratorProgress: hadoop.localdomain.38: Transitioning from INIT (PT0.004S) to CONNECT
2019-03-06 19:37:18,080 INFO scm-web-300:com.cloudera.enterprise.JavaMelodyFacade: Exiting HTTP Operation: Method:POST, Path:/add-hosts-wizard/install, Status:200
2019-03-06 19:37:18,080 INFO NodeConfiguratorThread-20-0:net.schmizz.sshj.transport.TransportImpl: Client identity string: SSH-2.0-SSHJ_0_14_0
2019-03-06 19:37:18,093 INFO NodeConfiguratorThread-20-0:net.schmizz.sshj.transport.TransportImpl: Server identity string: SSH-2.0-OpenSSH_7.4
2019-03-06 19:37:18,124 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfiguratorProgress: hadoop.localdomain.38: Transitioning from CONNECT (PT0.046S) to AUTHENTICATE
2019-03-06 19:37:18,203 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfiguratorProgress: hadoop.localdomain.38: Transitioning from AUTHENTICATE (PT0.078S) to MAKE_TEMP_DIR
2019-03-06 19:37:18,249 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfigurator: Executing mktemp -d /tmp/scm_prepare_node.XXXXXXXX on hadoop.localdomain.38
2019-03-06 19:37:18,299 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfiguratorProgress: hadoop.localdomain.38: Transitioning from MAKE_TEMP_DIR (PT0.097S) to COPY_FILES
2019-03-06 19:37:18,500 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfigurator: Using key bundle from URL: https://archive.cloudera.com/cm6/6.0.1/allkeys.asc
2019-03-06 19:37:18,653 INFO NodeConfiguratorThread-20-0:com.cloudera.server.cmf.node.NodeConfiguratorProgress: hadoop.localdomain.38: Setting COPY_FILES as failed and done state
2019-03-06 19:37:18,653 INFO NodeConfiguratorThread-20-0:net.schmizz.sshj.transport.TransportImpl: Disconnected - BY_APPLICATION
2019-03-06 19:37:23,105 ERROR CommandPusher:com.cloudera.cmf.command.flow.WorkOutputs: CMD id: 3767 Failed to complete installation on host hadoop.localdomain.38.
2019-03-06 19:37:23,105 ERROR CommandPusher:com.cloudera.cmf.model.DbCommand: Command 3767(GlobalHostInstall) has completed. finalstate:FINISHED, success:false, msg:Failed to complete installation.
2019-03-06 19:37:23,490 INFO avro-servlet-hb-processor-0:com.cloudera.server.common.AgentAvroServlet: (3 skipped) AgentAvroServlet: heartbeat processing stats: average=13ms, min=10ms, max=39ms.
2019-03-06 19:37:23,655 INFO scm-web-465:com.cloudera.enterprise.JavaMelodyFacade: Entering HTTP Operation: Method:POST, Path:/add-hosts-wizard/installprogressdata.json
2019-03-06 19:37:23,656 INFO scm-web-465:com.cloudera.enterprise.JavaMelodyFacade: Exiting HTTP Operation: Method:POST, Path:/add-hosts-wizard/installprogressdata.json, Status:200
2019-03-06 19:37:53,438 INFO scm-web-463:com.cloudera.enterprise.JavaMelodyFacade: Entering HTTP Operation: Method:POST, Path:/add-hosts-wizard/installprogress
2019-03-06 19:37:53,439 INFO scm-web-463:com.cloudera.enterprise.JavaMelodyFacade: Exiting HTTP Operation: Method:POST, Path:/add-hosts-wizard/installprogress, Status:200what could be the issue ?
Created 03-07-2019 07:46 AM
Created 03-06-2019 05:20 PM
Created 03-07-2019 12:40 AM
Created 03-07-2019 07:46 AM