Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ambari Fails to create Keytabs when Installing new services or when trying to regenerate keytabs of existing services

avatar
Explorer

I am getting a server action failed error when ambari tries to create keytabs. I have no idea what is causing this error. I am using KDC admin to install the service. Please help. @Geoffrey Shelton Okot

96567-keytab-error.png

1 ACCEPTED SOLUTION

avatar
Master Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
27 REPLIES 27

avatar

Interesting.... Actually I am not sure why `UNKNOWN:normal` is in there. Did you edit the encryption types in the configure Kerberos page, under Advanced kerberos-env? It should be `aes des3-cbc-sha1 rc4 des-cbc-md5`. Does your have a different value?

avatar
Master Mentor

@huzaira bashir

Can you share your krb5 and kdc conf files for analysis?


avatar
Explorer
@Geoffrey Shelton Okot

Find attached the 2 files

avatar

One thing to note is that Ambari appears to not be managing the krb5.conf file. This is fine, but Hadoop does not support the KEYRING cache type. You need to change

 default_ccache_name = KEYRING:persistent:%{uid}

to

default_ccache_name = /tmp/krb5cc_%{uid}

avatar
Master Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

This is to the point! I got the same error when tried changing the default Ambari suggested enctypes to my custom ones. The custom ones work fine though with MIT KDC, but apparantly not with Ambari.

avatar
Explorer

@Geoffrey Shelton Okot So hashing out the the line in kdc.conf was not enough to make the errors go away, but when I changed the default config in Ambari to only 2 encryption types and hashed out the default ticket encryptions as well. the error went away. Thanks for all your help.

avatar
New Contributor

thank you so much. I encountered same problem,but it solved after read your solution.

I also changed the default config in Ambari to only 2 encryption types and hashed out the default ticket encryptions as well, then error went away.