Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

Solved Go to solution
Highlighted

Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

Hi Ward,

Thank you so much for your reply.

I got the way to solution after investigating region-server log.

Region server was actually trying to open some old service which was already removed long ago but due to some reasons "that service related directories and metadata was left under /app/hbase/data/service_name folder" which was responsible for main error.

As soon as I have deleted /service_name/* from /app/hbase/data directory problem got solved. Of course I restarted HBASE service from Ambari.

Thanks

View solution in original post

3 REPLIES 3
Highlighted

Re: Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

Hi Abhishek,

Seems Ambari can't connect to the HBASE Region Server. Sometimes a (re)start of the service fixes this. If not, anything in the hbase region server log?

Re: Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

Hi Ward,

Thank you so much for your reply.

I got the way to solution after investigating region-server log.

Region server was actually trying to open some old service which was already removed long ago but due to some reasons "that service related directories and metadata was left under /app/hbase/data/service_name folder" which was responsible for main error.

As soon as I have deleted /service_name/* from /app/hbase/data directory problem got solved. Of course I restarted HBASE service from Ambari.

Thanks

View solution in original post

Highlighted

Re: Ambari HBASE Region Server fails with 'Connection failed: [Errno 111] Connection refused to hostname(SLAVE NODE ADDRESS):16030'

Explorer

in hdp 3.1 the file is in app/hbase/data/Wal's you will find the server name that wont start ==> delete it

Don't have an account?
Coming from Hortonworks? Activate your account here