Support Questions
Find answers, ask questions, and share your expertise

Ambari Metrics Grafana dashboards showing no datapoints

Solved Go to solution

Ambari Metrics Grafana dashboards showing no datapoints

I recently upgraded cluster to HDP 2.6.4.0 from 2.5.3.0 and Ambari to 2.5.1.0. After cluster upgrade, Grafana dashboards for System - Servers show "No datapoints." Dropdown for cluster in dashboards doesn't have correct value for cluster. Please see attached screenshot.screen-shot-2018-01-31-at-100524-am.png

How can I fix this ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ambari Metrics Grafana dashboards showing no datapoints

Expert Contributor

Can you upgrade Ambari to 2.5.2 or AMS only to 2.5.2? This most likely a known issue:

https://issues.apache.org/jira/browse/AMBARI-21640

View solution in original post

4 REPLIES 4

Re: Ambari Metrics Grafana dashboards showing no datapoints

Expert Contributor

Can you upgrade Ambari to 2.5.2 or AMS only to 2.5.2? This most likely a known issue:

https://issues.apache.org/jira/browse/AMBARI-21640

View solution in original post

Re: Ambari Metrics Grafana dashboards showing no datapoints

Thank You. You pointed me in right direction.

Re: Ambari Metrics Grafana dashboards showing no datapoints

New Contributor

I have same issue with Ambari 2.7.3 . Cluster name is not populated in template. Can you guide?

Re: Ambari Metrics Grafana dashboards showing no datapoints

New Contributor

my ambari version is 2.7.1.0. my 'System - Home' dashboards has data. but 'Ambari Server - Database' , 'Ambari Server - JVM' and 'Ambari Server -TopN Entities' has no datapoints. did you solve the problem?