Support Questions

Find answers, ask questions, and share your expertise

Ambari:Problem accessing /webhdfs/v1/ats/done Error while enabling kerberos


I have installed Ambari 2.5.0 version with HDP 2.6 and added some of the services but while enabling kerberos I am facing one weird issue.

resource_management.core.exceptions.Fail: Execution of 'curl -sS -L -w '%
{http_code}' -X GET --negotiate -u : 'http://xxxx:50070/webhdfs/v1/ats/done?
op=GETFILESTATUS&'' returned status_code=403. 
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
  <title>Error 403

<body><h2>HTTP ERROR 403</h2>
<p>Problem accessing /webhdfs/v1/ats/done. Reason:
  </p><hr /><i><small>Powered by Jetty://</small></i><br/>                                                

My installation is getting failed while installing the APP time line server and in the log file there is nothing coming.Everything was working fine before but suddenly it landed into this issue. Any suggestions will be appreciated.



Did you try HDFS Service check? Is it successful?

View solution in original post



Did you try HDFS Service check? Is it successful?

Yes it is failing after kerberos is enabled with error message: ixxxx:50070: Unexpected HTTP response: code=403 != 200, op=GETDELEGATIONTOKEN,

ambari logged in user:admin

i have also generated ticket for HTTP with spengo keytab for admin user.


I had the same issue which was due to mixed case of hostname.

I ensured that the hostname is uniform(lower case) and restarted the server.

This fixed the issue.

Thanks a lot.It worked for me after making the hostname to lower case.

New Contributor

Thanks, It worked for me too.When updating my hostname to lower case.