Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Ambari Server Restarted, now Web Interface Won't Load


I have a cluster that has been running pretty smoothly for over a month now that is rather large. I had just fixed an issue with a few DataNodes and was left with the web interface saying that 5 hosts were in maintenance mode when they were not. I tried turning mm on/off but it didn't help so I finally tried a sudo ambari-server restart

Afterwards, I tried to login again and the web interface wouldn't load. Waited a few minutes, still nada.

Looking at today's entries in /var/log/ambari-server/ambari-server.log had errors regarding the metric server but nothing that seemed relevant. The network settings are all the same and haven't changed, I am not sure what went wrong? Any ideas of what logs I should read or what I should try?


Thanks for the fast replies!!

I have attached the info requested as files so this post doesn't extend down a mile.

It looks like the ambari service is not listening on port 8080.


I ended up rolling back the ambari server vm to an earlier checkpoint and luckily there weren't too many errors to deal with. I will update again if the issue comes back.



Could you also restart the ambari agents of your cluster. It'd be good to have some of the errors that you saw in the ambari-server log, could you post some of the log or upload the log file?

After you restarted the ambari server, did it show up in the process (ps -aux | grep ambari-server), also make sure you see the ambari process listening on port 8080 (netstat -anop)

View solution in original post


New Contributor

Hi @Kyle Pifer: I have been facing the exact same issue as you. I went through all the steps mentioned above . However, port 8080 doesnt listen at all and no luck in moving on to ambari. The max i ve been able to proceed to is the hortonworks sandbox through the ip(default port 80).


Tried most of suggestions, those did not work. Simply restarted Sandbox (by shut down option); Restored network ,NAT related settings .Now i am able to login to ambari, ssh client


Hi Laxmikant Deshmukh,

Can u just explain it in brief? because i am also facing the same issue, i have also tried all the option but not able to get UI of ambari. my ambari server is running agent is also running. only UI of ambari is not coming in browser. Please help. facing this issue from so many days.


Hi Urmila, just reset the changes if u have done any (example- you might have changed network type to Bridged Adapter etc. as per suggestions etc.) Choose shut down option while closing the HDP sandbox.Then Start sandbox from virtual box.U will be able to access Ambari n other places once u login


@Kyle Pifer, I know you found a workaround now; nevertheless, we found the solution (because we experienced the same issue, the hard way): tez view is the problem.

If you look at your ambari-server.log, you can see it tries to deploy the tez view, but never confirms it did.

I don't know what's wrong with the tez view, neither why it only prevents starting ambari now since we did thousands of server restart for the past year, but if you move the tez view jar in /var/lib/ambari-server/resources/views to another folder, then ambari will start properly.

Now, if you need the tez view, debugging it is another story...

Hope this helps,