Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
/Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/AMBARI_METRICS/package/scripts/metrics_collector.py", line 90, in <module>
AmsCollector().execute()
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 355, in execute
self.execute_prefix_function(self.command_name, 'post', env)
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 382, in execute_prefix_function
method(env)
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 424, in post_start
raise Fail("Pid file {0} doesn't exist after starting of the component.".format(pid_file))
resource_management.core.exceptions.Fail: Pid file /var/run/ambari-metrics-collector//hbase-ams-master.pid doesn't exist after starting of the component./
Created 11-18-2019 02:24 AM
Hi@Manoj690 ,
Seems your AMS hbase master is not able to start -
Please try below steps -
Eg. #cp /var/lib/ambari-metrics-collector/hbase-tmp/* /tmp/
#rm –fr /var/lib/ambari-metrics-collector/hbase-tmp/*
#/usr/hdp/current/zookeeper-client/bin/zkCli.sh
#rmr /ams-hbase-secure
Let know if you still have issue
Created 11-18-2019 02:24 AM
Hi@Manoj690 ,
Seems your AMS hbase master is not able to start -
Please try below steps -
Eg. #cp /var/lib/ambari-metrics-collector/hbase-tmp/* /tmp/
#rm –fr /var/lib/ambari-metrics-collector/hbase-tmp/*
#/usr/hdp/current/zookeeper-client/bin/zkCli.sh
#rmr /ams-hbase-secure
Let know if you still have issue