Support Questions
Find answers, ask questions, and share your expertise

Apache Metron Single Node installation problems

Contributor

Hi,

I am trying to setup single node via vagrant but no matter what i try it keeps up throwing error. Can you please guide what could be the solution ?

error-while-vagrantup.png

TASK [libselinux-python : Install libselinux-python] ***************************

fatal: [node1]: FAILED! => {"failed": true, "msg": "ERROR! The conditional check 'result.rc == 0' failed. The error was: ERROR! error while evaluating conditional (result.rc == 0): ERROR! 'dict object' has no attribute 'rc'"}

After this i tried vagrant provision which solved that but gave a new kind of error.

TASK [yum-update : Yum Update Packages] ****************************************

fatal: [node1]: FAILED! => {"failed": true, "msg": "ERROR! The conditional check 'result.rc == 0' failed. The error was: ERROR! error while evaluating conditional (result.rc == 0): ERROR! 'dict object' has no attribute 'rc'"}
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Apache Metron Single Node installation problems

Contributor

Thanks to all, this problem was resolved when I increased the RAM to 64 GB

View solution in original post

19 REPLIES 19

Re: Apache Metron Single Node installation problems

Explorer

@Farrukh Anjum

Hi Farrukh,

Could you please ensure you are running the metron installation with the following versions of ansible and vagrant?

ansible= 2.0.0.2
Vagrant =1.8.1

Inorder to debug the mentioned issue,will need the log at the verbose level so would request you to run ansible provisioning by adding the following line in your Vagrantfile.(metron-deployment/vagrant/quick-dev-platform/Vagrantfile)

ansible.verbose = "vvv"

Regards,

Neha

Re: Apache Metron Single Node installation problems

Explorer

On top of ansible and vagrant versions mentioned by @Neha Sinha, it is important to have Python 2.7.11. I believe this error is due to incorrect python version.

Re: Apache Metron Single Node installation problems

Super Collaborator

I had earlier successfully deployed a 12-node Metron cluster on EC2 using a Ubuntu 14.04 box. Here are the steps that worked for me.

  • Installed Linuxbrew
  • Installed Java 1.8.0 and mvn 3.3.9
  • Python 2.7.11 with virtualenv (see this post for details)
  • Install Ansible ver 2.0.0.2 (after activating the virtualenv, using the command 'pip install ansible==2.0.0.2')
  • Install Virtualbox 5.0.16 and Vagrant 1.8.1

Can you post the output of 'incubator-metron/metron-deployment/scripts/platform-info.sh' from your setup?

Re: Apache Metron Single Node installation problems

New Contributor

hello @asubramanian i need to contact you, if you allow, i have couple of questions on metron, if you could give me your email, iam student and i have metron to setup and iam in loop of installation problems

Re: Apache Metron Single Node installation problems

Contributor

Well I uninstalled Ubuntu and installed CentOS 6.8 on Server hopping that it will make it smooth installation but its like out of pain into the fire like situation.

I am getting this error. Any help will be appericated.

2016-08-2908:00:54,504 p=2522 u=root |  TASK [ambari_master :Install ambari server]***********************************2016-08-2909:25:57,232 p=2522 u=root |  fatal:[node1]: UNREACHABLE!=>{"changed":false,"msg":"Failed to connect to the host via ssh.","unreachable":true}

Re: Apache Metron Single Node installation problems

Super Collaborator

Hey @Farrukh Anjum, can you post the output of 'incubator-metron/metron-deployment/scripts/platform-info.sh' from your setup?

Re: Apache Metron Single Node installation problems

Contributor

Metron 0.2.0BETA fatal: Not a git repository (or any of the parent directories): .git -- ansible 2.1.1.0 config file = /etc/ansible/ansible.cfg configured module search path = Default w/o overrides -- Vagrant 1.8.1 -- Python 2.6.6 -- Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T21:41:47+05:00) Maven home: /usr/share/apache-maven Java version: 1.7.0_111, vendor: Oracle Corporation Java home: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.111.x86_64/jre Default locale: en_US, platform encoding: UTF-8 OS name: "linux", version: "2.6.32-642.el6.x86_64", arch: "amd64", family: "unix" -- Linux CentOS17 2.6.32-642.el6.x86_64 #1 SMP Tue May 10 17:27:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Re: Apache Metron Single Node installation problems

Super Collaborator

I can see that you're missing the following because of which you're running into the issues.

- Python needs to be 2.7.x (you're having 2.6.6)

- ansible needs to be 2.0.0.2 (you're running on 2.1.1.0)

- Java needs to be 1.8.x (and you're running with 1.7.0_111)

Can you fix the above and retry?

For your reference, here's the output from my single node setup (it is from a Mac box, but nevertheless)

(testmetron) asubramanian:incubator-metron-fork asubramanian$ ./incubator-metron/metron-deployment/scripts/platform-info.sh
Metron 0.2.0BETA
fatal: Not a git repository (or any of the parent directories): .git
--
ansible 2.0.0.2
  config file =
  configured module search path = Default w/o overrides
--
Vagrant 1.8.4
--
Python 2.7.10
--
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T22:11:47+05:30)
Maven home: /usr/local/Cellar/maven/3.3.9/libexec
Java version: 1.8.0_91, vendor: Oracle Corporation
Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_91.jdk/Contents/Home/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "mac os x", version: "10.11.6", arch: "x86_64", family: "mac"
--
Darwin asubramanian.local 15.6.0 Darwin Kernel Version 15.6.0: Thu Jun 23 18:25:34 PDT 2016; root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64

Re: Apache Metron Single Node installation problems

Contributor
./metron-deployment/scripts/platform-info.shMetron 0.2.0BETA
fatal: Not a git repository (or any of the parent directories): .git
--
ansible 2.0.0.2
  config file = 
  configured module search path = Default w/o overrides
--
Vagrant 1.8.1
--
Python 2.7.11
--
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T21:41:47+05:00)
Maven home: /usr/share/apache-maven
Java version: 1.8.0_45, vendor: Oracle Corporation
Java home: /usr/java/jdk1.8.0_45/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "2.6.32-642.el6.x86_64", arch: "amd64", family: "unix"
--
Linux CentOS17 2.6.32-642.el6.x86_64 #1 SMP Tue May 10 17:27:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux