Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-24-2023 01:23 AM - edited 03-24-2023 01:24 AM
Hi, All!
I have a problem with NIFI ListSFTP processor. After started processor errored with
Failed to properly initialize Processor. If still scheduled to run, NiFi will attempt to initialize and run the Processor again after the 'Administrative Yield Duration' has elapsed. Failure is due to java.lang.IllegalArgumentException: A HostProvider may not be empty!: java.lang.IllegalArgumentException: A HostProvider may not be empty!
ListSFTP processor Version 1.12.0 and the Properties as follows:
Error screenshot from UI:
Created 03-24-2023 02:35 AM
hi @hackerway,
It seems that you have the same exact issue as posted here: https://community.cloudera.com/t5/Support-Questions/NiFi-ListSTFP-hostprovider-may-not-be-empty/m-p/...
I had the same issue and what @MattWho said in that post helped me solve my issue 🙂
Have a look to the solution and try to see if it will solve your issue.
In addition to the above link, you can also have a look on: https://stackoverflow.com/questions/59826510/a-hostprovider-may-not-be-empty-after-upgrading-to-nifi...
Created 03-24-2023 02:35 AM
hi @hackerway,
It seems that you have the same exact issue as posted here: https://community.cloudera.com/t5/Support-Questions/NiFi-ListSTFP-hostprovider-may-not-be-empty/m-p/...
I had the same issue and what @MattWho said in that post helped me solve my issue 🙂
Have a look to the solution and try to see if it will solve your issue.
In addition to the above link, you can also have a look on: https://stackoverflow.com/questions/59826510/a-hostprovider-may-not-be-empty-after-upgrading-to-nifi...
Created 03-24-2023 04:17 AM
Hi @cotopaul Thanks for the response. As you rightly pointed out, it's the same issue. However, I'm still facing the problem. I have configured the 'zookeeper.properties' as below:
Created 03-24-2023 04:34 AM
@hackerwayhow does your state-management.xml look like? Are you using the embedded zookeeper by any chance?
Created 03-24-2023 06:14 PM
Thanks @cotopaul state-management.xml Connect String was missing , Yes