Support Questions

Find answers, ask questions, and share your expertise

Apache Nifi Service running fine, but UI not working in browser

I have installed nifi-0.6.0.1.2.0.1-1 on Hortonworks sandbox. When I run the service using the commands, it is showing that service is running successfully. However, I couldn't get UI on the browser to build a DataFlow.

INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is currently running, listening to Bootstrap on port 50355, PID=26547

*Firewall is switched off

* Modified the Nifi port number to 9090 on nifi.properties file

6 REPLIES 6

Rising Star
@Sai Dileep

that log message indicates that the NiFi process has started, and it is listening for "shutdown" commands, etc. from the bootstrap. However, it does not indicate that the dataflow has started or that the web UI is ready. It will typically take 1-2 minutes to startup. Do you have anything else in the nifi-app.log file? If not, can you check the nifi-bootstrap.log file and see if there is something going on there? Additionally, in the conf/bootstrap.conf file, please make sure that you don't have the process setup to listen for a Remote Debugger. That would be done by looking for this line around line 39 in the file:

#java.arg.debug=-agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=8000

If you see that the above line is un-commented and that suspend=y, that could cause the process to not finish starting.

@mpayne I have checked conf/bootstrap.conf file and that line which you have mentioned is exactly the same way as expected. It is commented out and suspend=y.

Also, there is nothing unusual in the nifi-app.log or nifi-bootstrap.log files. I didn't find any ERROR messages over there.

Ok, so this is a sandbox. Have you configured port forwarding for this VM?

New Contributor

peaaase i hav the same problm , u can help me!!!!

,

i have the same problem , please u can help me !!!!

Expert Contributor

Have you tried downloading HDF instead: http://hortonworks.com/downloads/#dataflow

(HDF 1.2.0.1: Hortonworks DataFlow)

Similar install process. I had noticed a similar issue when I was using the sandbox and downloaded NiFi vs. HDF.

New Contributor

I had similar issue today, where Nifi server was up, but UI kept spinning.  I did clear browser cache and restarted the server, and browser.  The UI came back fine.  Just mentioning it for others, who may have similar issue, 

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.