Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
04-21-2020
04:52 PM
- last edited on
04-21-2026
04:30 AM
by
GrazittiAPI
Hi there,
I added Atlas in my CDP cluster, and find can't connect the web UI.
In the application.log, I found the error: Can not find the specified config set: vertex_index.
I followed the instruction in the following links, but still couldn't get it to work. Any suggestions?
https://issues.apache.org/jira/browse/AMBARI-18368
Here is the application.log:
Atlas Server (STARTUP)
project.name: apache-atlas
project.description: Metadata Management and Data Governance Platform over Hadoop
build.user: jenkins
build.epoch: 1574150696506
project.version: 2.0.0.7.0.3.0-79
build.version: 2.0.0.7.0.3.0-79
vc.revision: cbb309de67ee0215efa0763f03c2f32f40f1d8f3
vc.source.url: scm:git:git://git.apache.org/atlas.git/atlas-webapp
######################################################################################## (Atlas:215)
2020-04-21 16:41:34,562 INFO - [main:] ~ >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> (Atlas:216)
2020-04-21 16:41:34,562 INFO - [main:] ~ Server starting with TLS ? false on port 31000 (Atlas:217)
2020-04-21 16:41:34,562 INFO - [main:] ~ <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< (Atlas:218)
2020-04-21 16:41:35,236 INFO - [main:] ~ No authentication method configured. Defaulting to simple authentication (LoginProcessor:102)
2020-04-21 16:41:35,315 WARN - [main:] ~ Unable to load native-hadoop library for your platform... using builtin-java classes where applicable (NativeCodeLoader:60)
2020-04-21 16:41:35,397 INFO - [main:] ~ Logged in user atlas (auth:SIMPLE) (LoginProcessor:77)
2020-04-21 16:41:36,202 INFO - [main:] ~ Not running setup per configuration atlas.server.run.setup.on.start. (SetupSteps$SetupRequired:189)
2020-04-21 16:41:38,552 WARN - [main:] ~ given scan urls are empty. set urls in the configuration (Reflections:181)
2020-04-21 16:41:38,635 WARN - [main:] ~ org.apache.solr.client.solrj.impl.Krb5HttpClientBuilder is configured without specifying system property 'java.security.auth.login.config' (Krb5HttpClientBuilder:142)
2020-04-21 16:41:39,523 INFO - [main:] ~ ==> KafkaNotification() (KafkaNotification:105)
2020-04-21 16:41:39,524 INFO - [main:] ~ <== KafkaNotification() (KafkaNotification:137)
2020-04-21 16:41:39,562 INFO - [main:] ~ Creating indexes for graph. (GraphBackedSearchIndexer:286)
2020-04-21 16:41:40,629 INFO - [main:] ~ Created index : vertex_index (GraphBackedSearchIndexer:291)
2020-04-21 16:41:40,645 INFO - [main:] ~ Created index : edge_index (GraphBackedSearchIndexer:297)
2020-04-21 16:41:40,655 INFO - [main:] ~ Created index : fulltext_index (GraphBackedSearchIndexer:303)
2020-04-21 16:41:40,775 ERROR - [main:] ~ GraphBackedSearchIndexer.initialize() failed (GraphBackedSearchIndexer:353)
org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException: Error from server at http://xxx:8983/solr: Can not find the specified config set: vertex_index
at org.apache.solr.client.solrj.impl.HttpSolrClient.executeMethod(HttpSolrClient.java:627)
at org.apache.solr.client.solrj.impl.HttpSolrClient.request(HttpSolrClient.java:253)
at org.apache.solr.client.solrj.impl.HttpSolrClient.request(HttpSolrClient.java:242)
Created on 05-07-2020 08:04 PM - edited 05-07-2020 08:37 PM
@Yong
Kindly ssh to the Atlas Server node and perform the below commands:
- cd /var/run/cloudera-scm-agent/process/XXXXXXX-atlas-ATLAS_SERVER/conf
Note: XXXXXX is a numerical number of the latest Atlas server process dir.
- solrctl instancedir --create atlas_configs solr (this will create a config vertex_index using the configs in solr folder in /var/run/cloudera-scm-agent/process/XXXXXXX-atlas-ATLAS_SERVER/conf).
- Restart Atlas Service and verify if the issue is resolved.
Created on 05-07-2020 08:04 PM - edited 05-07-2020 08:37 PM
@Yong
Kindly ssh to the Atlas Server node and perform the below commands:
- cd /var/run/cloudera-scm-agent/process/XXXXXXX-atlas-ATLAS_SERVER/conf
Note: XXXXXX is a numerical number of the latest Atlas server process dir.
- solrctl instancedir --create atlas_configs solr (this will create a config vertex_index using the configs in solr folder in /var/run/cloudera-scm-agent/process/XXXXXXX-atlas-ATLAS_SERVER/conf).
- Restart Atlas Service and verify if the issue is resolved.