Support Questions
Find answers, ask questions, and share your expertise

Atlas is empty after hive table creation

New Contributor

Hello,

 

I started a test CDP 7.1.7 cluster, added some files in HDFS and created tables in Hive.

However Atlas is empty. I expected to find at least some hive_table and hdfs_path items.

 

The result is the same if I use a custom user (with Atlas ADMIN profile) or with the predefined admin user.

 

No error is displayed.

 

Is there something I was supposed to do I missed ?

What is my next action to populate Atlas or to find what is missing ?

 

Thank you,

Jérôme

1 ACCEPTED SOLUTION

Cloudera Employee

Hello @jxerome,

1. After you install Atlas in the CDP cluster, you need to configure "Atlas" dependency in Hive on Tez (OR Hive if you use Spark as the execution engine) service, you can do that by following:

 

CM UI > Hive on Tez > Configurations > Check the "atlas" checkbox. This would configure Atlas-Hive hooks for your cluster. 

EX:

Screenshot 2021-09-23 at 4.50.58 PM.png

 

2. After this please restart Atlas and Hive service.

3. For the first time there will be no metadata synced from Hive to Atlas. You need to manually sync all the data using the atlas bridge (import-hive.sh script). This should be run with an admin user who has permissions in Hive as well as Atlas.
4. In your case, if 1. is not configured properly, then metadata will not be synced automatically.

Let me know how that goes for you!

View solution in original post

2 REPLIES 2

Cloudera Employee

Hello @jxerome,

1. After you install Atlas in the CDP cluster, you need to configure "Atlas" dependency in Hive on Tez (OR Hive if you use Spark as the execution engine) service, you can do that by following:

 

CM UI > Hive on Tez > Configurations > Check the "atlas" checkbox. This would configure Atlas-Hive hooks for your cluster. 

EX:

Screenshot 2021-09-23 at 4.50.58 PM.png

 

2. After this please restart Atlas and Hive service.

3. For the first time there will be no metadata synced from Hive to Atlas. You need to manually sync all the data using the atlas bridge (import-hive.sh script). This should be run with an admin user who has permissions in Hive as well as Atlas.
4. In your case, if 1. is not configured properly, then metadata will not be synced automatically.

Let me know how that goes for you!

New Contributor

Hello @Parth_Pathak ,

 

The "atlas" checkboxes were already checked.

 

However, I was able to populate Atlas with the import-hive.sh script.

Which is enough for now.

 

Thank you,

; ;