Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

CA Certificates Error when trying to connect with Impala Driver LINUX

avatar
Frequent Visitor

I followed the instructions here for setting up and configuring the Impala driver on Linux.  When I test the connection using the isql command line utility I get the following error:

 

 

[S1000][unixODBC][Cloudera][DriverSupport] (1140) Unable to load CA certificates from certs file location.  Please ensure the file exists, has read permission, and has the correct PEM format.
[ISQL]ERROR: Could not SQLConnect

 

 

 

My odbc.ini looks like this: 

 

 

[ODBC Data Sources]

[hadoop]
  Driver=Cloudera ODBC Driver for Impala 64-bit
  AllowHostNameCNMismatch=1
  AllowSelfSignedServerCert=1
  AuthMec=3
  CheckCertRevocation=1
  DelegateKrbCreds=0
  Host={myhost}
  KrbFQDN=_HOST
  KrbRealm={myrealm}
  KrbServiceName=impala
  Min_TLS=1.2
  Port=21050
  ServicePrincipalCanonicalization=1
  SSL=1
  TrustedCerts=/opt/cloudera/impalaodbc/lib/64/cacerts.pem
  UseKeytab=0
  UseOnlySSPI=1
  UseSASL=1
  UseSystemTrustStore=1

 

 

 

And the permission on /opt/cloudera/imapalaodbc/lib/64/cacerts.pem is set to 777: 

 

 

 

-rwxrwxrwx 1 userXXX groupXXX 246K Dec 31  2018 /opt/cloudera/impalaodbc/lib/64/cac                     erts.pem

 

 

 

Can anyone help resolve this error?  The cacerts.pem file has the right permission and the file certainly exists. 

 

1 ACCEPTED SOLUTION

avatar
Frequent Visitor

Oops.  Reading the docs it mentions "UseSystemTrustStore" is only valid for windows.  Removing this value from by odbc.ini fixes this issue.

View solution in original post

1 REPLY 1

avatar
Frequent Visitor

Oops.  Reading the docs it mentions "UseSystemTrustStore" is only valid for windows.  Removing this value from by odbc.ini fixes this issue.