Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
01-26-2023
09:01 AM
- last edited on
04-21-2026
12:45 AM
by
GrazittiAPI
Hi, trying to set placement rules as described in https://docs.cloudera.com/cdp-private-cloud-base/7.1.6/yarn-allocate-resources/topics/yarn-placement-rule-policies.html, but tasks still in default queue.
Also tried to enable tag-based authorization with the same result.
What could be wrong?
Created 04-05-2023 08:33 AM
You do not have any value for the user name. "This rule mactches: users named <your_user>".
When you fill the rule you should set the name (or group, or application name) of the user that match your placement rule.
Created 04-07-2023 06:44 AM
Username is set, but deteted due to security reasosns
Created 04-11-2023 12:59 AM
found in yarn logs records like
failed to save service-tags to cache file '/var/lib/ranger/yarn/policy-cache/yarn_cm_yarn_tag.json' java.io.FileNotFoundException: /var/lib/ranger/yarn/policy-cache/yarn_cm_yarn_tag.json (Permission denied)
Could it be the core reason?
How can i fix it?
Created 04-13-2023 12:25 AM
Created 04-17-2023 02:31 AM
ls: cannot access '/var/lib/ranger/yarn/': No such file or directory