Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

CFM- Nifi service is not starting due to "ERROR org.springframework.web.context.ContextLoader: Context initialization failed"

avatar
Contributor

Nifi service is not coming up due to the error 

/var/log/nifi/nifi-app.log

 

2019-08-16 14:45:57,385 ERROR org.springframework.web.context.ContextLoader: Context initialization failed

org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'org.springframework.security.config.annotation.web.configuration.WebSecurityConfiguration': Unsatisfied dependency expressed through method 'setFilterChainProxySecurityConfigurer' parameter 1; nested exception is org.springframework.beans.factory.BeanExpressionException: Expression parsing failed; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'org.apache.nifi.web.NiFiWebApiSecurityConfiguration': Unsatisfied dependency expressed through method 'setJwtAuthenticationProvider' parameter 0; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'jwtAuthenticationProvider' defined in class path resource [nifi-web-security-context.xml]: Cannot resolve reference to bean 'jwtService' while setting constructor argument; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'jwtService' defined in class path resource [nifi-web-security-context.xml]: Cannot resolve reference to bean 'keyService' while setting constructor argument; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'keyService' defined in class path resource [nifi-administration-context.xml]: Cannot resolve reference to bean 'keyTransactionBuilder' while setting bean property 'transactionBuilder'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'keyTransactionBuilder' defined in class path resource [nifi-administration-context.xml]: Cannot resolve reference to bean 'keyDataSource' while setting bean property 'dataSource'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'keyDataSource': FactoryBean threw exception on object creation; nested exception is org.h2.jdbc.JdbcSQLException: Database may be already in use: "Locked by another process". Possible solutions: close all other connection(s); use the server mode [90020-176]

        at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor$AutowiredMethodElement.inject(AutowiredAnnotationBeanPostProcessor.java:666)

 

Any insights? 

Hemanth

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Another instance is running and blocking in background.

Check running processes and kill them

ps -ef | grep nifi 

after that, restart.

View solution in original post

5 REPLIES 5

avatar
Expert Contributor

Another instance is running and blocking in background.

Check running processes and kill them

ps -ef | grep nifi 

after that, restart.

avatar
Contributor

HI @Faerballert 

Thanks for reply.

I cannot find another instance running on the background.

[root@ip-172-31-15-238 ec2-user]# ps -ef | grep nifi
root 15458 15388 0 12:31 pts/0 00:00:00 grep --color=auto nifi
nifi 16931 11875 0 11:49 ? 00:00:00 /usr/bin/python2 /opt/cloudera/cm-agent/bin/cm proc_watcher 16939
nifi 16939 16931 0 11:49 ? 00:00:05 /usr/java/jdk1.8.0_181-cloudera//bin/java -cp /var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/bootstrap/* -Xms12m -Xmx24m -Dorg.apache.nifi.bootstrap.config.log.dir=/var/log/nifi -Dorg.apache.nifi.bootstrap.config.pid.dir=/var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE -Dorg.apache.nifi.bootstrap.config.file=/var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE/bootstrap.conf org.apache.nifi.bootstrap.RunNiFi run
nifi 16940 16931 0 11:49 ? 00:00:00 /usr/bin/python2 /opt/cloudera/cm-agent/bin/cm redactor --fds 3 5
nifi 17181 16939 14 11:49 ? 00:05:55 /usr/java/jdk1.8.0_181-cloudera/bin/java -classpath /var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/jul-to-slf4j-1.7.25.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/jetty-schemas-3.1.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/nifi-runtime-1.9.0.1.0.0.0-90.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/nifi-api-1.9.0.1.0.0.0-90.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/logback-core-1.2.3.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/jcl-over-slf4j-1.7.25.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/nifi-properties-1.9.0.1.0.0.0-90.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/slf4j-api-1.7.25.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/nifi-nar-utils-1.9.0.1.0.0.0-90.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/nifi-framework-api-1.9.0.1.0.0.0-90.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/javax.servlet-api-3.1.0.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/logback-classic-1.2.3.jar:/opt/cloudera/parcels/CFM-1.0.0.0/NIFI/lib/log4j-over-slf4j-1.7.25.jar -Dorg.apache.jasper.compiler.disablejsr199=true -Xmx512m -Xms512m -Djavax.security.auth.useSubjectCredsOnly=true -Djava.security.egd=file:/dev/urandom -Dsun.net.http.allowRestrictedHeaders=true -Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -XX:+UseG1GC -Djava.protocol.handler.pkgs=sun.net.www.protocol -Dnifi.properties.file.path=/var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE/nifi.properties -Dnifi.bootstrap.listen.port=36497 -Dapp=NiFi -Dorg.apache.nifi.bootstrap.config.log.dir=/var/log/nifi org.apache.nifi.NiFi -K /var/run/cloudera-scm-agent/process/45-nifi-NIFI_NODE/sensitive.key

 

I have killed the processes and restarted Nifi but still the same error message.

Hemanth

avatar
Contributor

Hi @Faerballert ,

Yes you are correct. Issue is resolved after restart of the Nifi node. 

Hemanth

avatar
Contributor

Hello Faerballert!  Sorry to barge into this thread.  I am also receiving this same error.  When I run the command you recommended, I obtain the following result:

 

dave@nificlient1:~/tools/nifi-1.19.1-bin/nifi-1.19.1/bin$ ps aux | grep nifi
avahi 1026 0.0 0.0 7756 3840 ? Ss 13:59 0:00 avahi-daemon: running [nificlient1.local]
dave 462448 0.0 0.0 6608 2228 pts/0 S+ 16:01 0:00 grep --color=auto nifi

 

How can i successfully kill these processes?

 

Thank you!

 

VR,

 

Dave

avatar
Contributor

What I am tryin mg to do is install a nifi cluster onto 3 Ubuntu 22.04 clients. I first installed nifi on each client independently. And then attempted to install a cluster using the same clients…I first stopped the nifi service running on each of the clients before attempting to install a cluster. 

Should I not install nifi separately on each of the clients before attempting to install the cluster?

 

thank you for any guidance