Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

CM cannot copy installation files to other servers

Solved Go to solution
Highlighted

Re: CM cannot copy installation files to other servers

Explorer

Thanks again :)

 

It's a bonded 4x10Gb with an MTU of 9000.

 

bond0     Link encap:Ethernet  HWaddr A0:36:9F:96:76:F4  
          inet addr:172.0.30.2  Bcast:172.0.30.255  Mask:255.255.255.0
          inet6 addr: fe80::a236:9fff:fe96:76f4/64 Scope:Link
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:9000  Metric:1
          RX packets:8750 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1500 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:616956 (602.4 KiB)  TX bytes:259076 (253.0 KiB)

Chris

Re: CM cannot copy installation files to other servers

Super Collaborator

based on issues I've seen they most leads to jumbo framing configuration :( could you verify that is working [1]

alternative installation path is to install the packages manually on the node, then vi /etc/cloudera-scm-agent/config.ini and set the Hostname of the CM server - server_host=....

 

eg;

yum clean all
rpm --import http://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/RPM-GPG-KEY-cloudera

# below is for the latest CM5 

# modify the baseurl in/etc/yum.repos.d/cloudera-manager.repo and point to the desire CM version

# example for version 5.5.1 baseurl=http://archive.cloudera.com/cm5/redhat/6/x86_64/cm/5.5.1/

wget http://archive.cloudera.com/cm5/redhat/6/x86_64/cm/cloudera-manager.repo -O /etc/yum.repos.d/cloudera-manager.repo
yum install -y oracle-j2sdk* cloudera-manager-{daemons,agent}

 

[1] https://www.mylesgray.com/hardware/test-jumbo-frames-working/

View solution in original post

Highlighted

Re: CM cannot copy installation files to other servers

Explorer

Ahhh....I think you are on to something for sure!  </happy_dance>

 

chris.neal@bdprodm09:[65]:~> ping -M do -s 8972 172.0.30.2
PING 172.0.30.2 (172.0.30.2) 8972(9000) bytes of data.
^C
--- 172.0.30.2 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1574ms

I'm going to ping our network guy and have him validate the switch configurations.  

 

Thank you thank you thank you. :)

I'll report back soon, I hope!

Chris

Highlighted

Re: CM cannot copy installation files to other servers

Explorer

Well, it seems the network guy has gone home for the day, so I set all the MTUs to 1500 between the CM server host and one agent server, and everything is working great. :) :)

 

Michalis, thank you again for taking the time to read my extra long posts and get me past this issue.

 

I'll have the network guy check the switches and firewall configuration and find out where the problem is ASAP tomorrow.  One more post back telling what the final issue ends up being.

 

Thanks again.

Chris

 

Highlighted

Re: CM cannot copy installation files to other servers

Explorer

Just one last reply to confirm that an improper switch configuration was the issue here.  Once that was fixed, everything worked great!

 

Thanks again for all the help.

Chris

Don't have an account?
Coming from Hortonworks? Activate your account here