Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Can't keep Hive service healthy

avatar
Explorer

Hello,

After cloudera cluster upgrade, the hive service becomes unhealthy after a few hours.

What i noticed is that the symlinks from /etc/alternatives are still pointing to the old parcel, but not sure if this is what makes the service unhealthy because I keep seeing the following error in the logs:

ERRORS:

Failed to get database cloudera_manager_metastore_canary_test_catalog_hive_HIVEMETASTORE_*

NoSuchObjectException(message:No catalog cloudera_manager_metastore_canary_test_catalog_hive_HIVEMETASTORE_*

Failed to delete hdfs://*/user/hue/.cloudera_manager_hive_metastore_canary/cloudera_manager_metastore_canary_test_catalog_hive_HIVEMETASTORE_*

 

Thank you!

1 REPLY 1

avatar
Master Collaborator

Hello @teo123 

Thank you for reaching out to the cloudera community

Yes old symlinks could be a reason for this 

Please try performing the steps mentioned in the following document 

 

https://my.cloudera.com/knowledge/Broken-Alternatives-Pointing-to-Previous-CDP-Parcels--Removing?id=...

 

In your case, if there are no broken symlinks, then remove the old symlinks from /etc/alternatives, and all steps will be the same

Let us know if you have any queries