Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Can't set mapreduce.shuffle.max.connections to 0

Solved Go to solution
Highlighted

Can't set mapreduce.shuffle.max.connections to 0

New Contributor

Hi,

 

I tried to set mapreduce.shuffle.max.connections to 0, but a validation error occured.

 

The doc says:

 

Set to 0 (zero) to indicate no limit on the number of connections.

 

Error: 0 is less than the minimum allowed value 1.

 

Please see the attached screenshot.

 

Version: Cloudera Enterprise Data Hub Edition Trial 5.2.0 (#60 built by jenkins on 20141012-2239 git: 179000584849e68f98ad2a7fe710723bd6c29c98)

 

CDH: 5.1.2

 

Regards,

 

mapreduce.shuffle.max.connections.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't set mapreduce.shuffle.max.connections to 0

Contributor

Hi Jiro,

 

Thanks for bringing this to our attention.  It appears there's a bug with the validation for that property, in which the lower bound should be 0 and not 1.  We'll get this fixed in a future release.  In the meantime, you can accomplish setting mapreduce.shuffle.max.connections to 0 by setting it in a specific Safety Valve in Cloudera Manager.  Please follow the directions listed below:

 

  1. Login to CM with admin privileges if you haven't done so already.
  2. Navigate to the YARN configuration page (CM -> Clusters -> YARN -> Configuration)
  3. Naviate to Gateway Default Group -> Advanced -> MapReduce Client Advanced Configuration Snippet (Safety Valve) for mapred-site.xml
  4. In the field marked Value, please enter in the following entry:
<property>
<name>mapreduce.shuffle.max.connections</name>
<value>0</value>
</property>
5. Save changes then Deploy client configuration

 

 

Kind Regards,

 

Anthony

 

View solution in original post

2 REPLIES 2

Re: Can't set mapreduce.shuffle.max.connections to 0

Contributor

Hi Jiro,

 

Thanks for bringing this to our attention.  It appears there's a bug with the validation for that property, in which the lower bound should be 0 and not 1.  We'll get this fixed in a future release.  In the meantime, you can accomplish setting mapreduce.shuffle.max.connections to 0 by setting it in a specific Safety Valve in Cloudera Manager.  Please follow the directions listed below:

 

  1. Login to CM with admin privileges if you haven't done so already.
  2. Navigate to the YARN configuration page (CM -> Clusters -> YARN -> Configuration)
  3. Naviate to Gateway Default Group -> Advanced -> MapReduce Client Advanced Configuration Snippet (Safety Valve) for mapred-site.xml
  4. In the field marked Value, please enter in the following entry:
<property>
<name>mapreduce.shuffle.max.connections</name>
<value>0</value>
</property>
5. Save changes then Deploy client configuration

 

 

Kind Regards,

 

Anthony

 

View solution in original post

Highlighted

Re: Can't set mapreduce.shuffle.max.connections to 0

New Contributor
Thanks!
Don't have an account?
Coming from Hortonworks? Activate your account here