Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Can't start Kafka Service broker

Solved Go to solution
Highlighted

Can't start Kafka Service broker

New Contributor

 

 

While starting kafka server its failing with below error.Tried with multiple versions. Please help with this

 

 

exception in thread "main" java.lang.UnsupportedClassVersionError:kafka/Kafka:Unsupported major.minor version 52.0

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't start Kafka Service broker

Cloudera Employee

Hi,

 

The 'major.minor version 52.0' error is possibly because the jar was compiled in JDK 1.8, but you are trying to run it using a JDK 1.7 environment. The reported number is the required number, not the number you are using. To solve this, it's always better to have the JDK and JRE pointed to the same version.

2 REPLIES 2

Re: Can't start Kafka Service broker

Rising Star
Hi,

Its showing that it is running in unsupported version. Could you let us know the below version

Kafka, CDH, System Java version.

'major.minor version 52.0' Will occur if you are running the application in JAVA version which is less than 1.8

Re: Can't start Kafka Service broker

Cloudera Employee

Hi,

 

The 'major.minor version 52.0' error is possibly because the jar was compiled in JDK 1.8, but you are trying to run it using a JDK 1.7 environment. The reported number is the required number, not the number you are using. To solve this, it's always better to have the JDK and JRE pointed to the same version.

Don't have an account?
Coming from Hortonworks? Activate your account here