Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Can't start Kafka Service broker

avatar
Visitor

 

 

While starting kafka server its failing with below error.Tried with multiple versions. Please help with this

 

 

exception in thread "main" java.lang.UnsupportedClassVersionError:kafka/Kafka:Unsupported major.minor version 52.0

1 ACCEPTED SOLUTION

avatar
Cloudera Employee

Hi,

 

The 'major.minor version 52.0' error is possibly because the jar was compiled in JDK 1.8, but you are trying to run it using a JDK 1.7 environment. The reported number is the required number, not the number you are using. To solve this, it's always better to have the JDK and JRE pointed to the same version.

View solution in original post

2 REPLIES 2

avatar
Expert Contributor
Hi,

Its showing that it is running in unsupported version. Could you let us know the below version

Kafka, CDH, System Java version.

'major.minor version 52.0' Will occur if you are running the application in JAVA version which is less than 1.8

avatar
Cloudera Employee

Hi,

 

The 'major.minor version 52.0' error is possibly because the jar was compiled in JDK 1.8, but you are trying to run it using a JDK 1.7 environment. The reported number is the required number, not the number you are using. To solve this, it's always better to have the JDK and JRE pointed to the same version.