Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Cannot create volume in Ozone

avatar
Explorer

Hello

 

I installed CDP 7.1.1 because I wanted to try Ozone. I played a little with apache Ozone in the past and wanted to see how it is in Cloudera.

 

After installation, I went ahead and tried to create a volume using this command (which complies with the documentation):

ozone sh volume create --quota=1TB --user=hdfs /tests

 

I got this error message:

"Service ID or host name must not be omitted when ozone.om.service.ids is defined."

 

I searched the internet for the error and did not find anything useful. I looked for ozone-site.xml file and found that ozone.om.service.id was "ozone1". But I do not know where in the command should I specify it. the command syntax does not take any service id or host name.

 

Why am I getting this error ? how can I specify service id or host name so the volume will be created ?

 

Thanks

 

Guy

1 ACCEPTED SOLUTION

avatar
Master Collaborator

Hi Guy,

 

Please try adjusting your command to the following:

ozone sh volume create --quota=1TB --user=hdfs o3://ozone1/tests

Note the documentation states that the last parameter is a URI in the format <prefix>://<Service ID>/<path>. Service Id is what you found in ozone-site.xml.

View solution in original post

1 REPLY 1

avatar
Master Collaborator

Hi Guy,

 

Please try adjusting your command to the following:

ozone sh volume create --quota=1TB --user=hdfs o3://ozone1/tests

Note the documentation states that the last parameter is a URI in the format <prefix>://<Service ID>/<path>. Service Id is what you found in ozone-site.xml.