Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Cannot start Ozone

avatar
Explorer

Hello,

 

i installed CDP 7.4.4 (trial), already enable TLS and Kerberos. I want to add  Ozone in CM but got a this error which is very confusing:

 

stdout:

Using /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER as conf dir
Using scripts/control.sh as process script
CONF_DIR=/var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER
CMF_CONF_DIR=
Wed Aug 30 16:09:11 +07 2023: Running OZONE CSD control script...
Wed Aug 30 16:09:11 +07 2023: Detected CDH_VERSION of [7]
Wed Aug 30 16:09:11 +07 2023: KERBEROS_AUTH_ENABLED: true
Wed Aug 30 16:09:11 +07 2023: OZONE_SSL_ENABLED: true
Wed Aug 30 16:09:11 +07 2023: OZONE_SERVICE_ID: hydg
Wed Aug 30 16:09:11 +07 2023: CONF_DIR: /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER
Wed Aug 30 16:09:11 +07 2023: Found Ozone Manager(s) on demo-2
Wed Aug 30 16:09:11 +07 2023: Found Ozone Storage Container Manager(s) on 'demo-1'
Could not find or is not a file

 

stderr:

+ TOPOLOGY_SCRIPT_FILE=
+ perl -pi -e 's#\{\{DEFAULT_TOPOLOGY_SCRIPT}}##g' /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/ozone-conf/ozone-site.xml
+ [[ true == \t\r\u\e ]]
+ [[ -n '' ]]
+ add_to_site /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/ozone-conf/ozone-site.xml ozone.acl.enabled false
+ '[' '!' -f /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/ozone-conf/ozone-site.xml ']'
+ CONF_END='</configuration>'
+ NEW_PROPERTY=' <property>\n <name>ozone.acl.enabled</name>\n <value>false</value>\n </property>'
+ TMP_FILE=/var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/tmp-core-site
+ sed 's#</configuration># <property>\n <name>ozone.acl.enabled</name>\n <value>false</value>\n </property>#g'
+ cp /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/tmp-core-site /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/ozone-conf/ozone-site.xml
+ rm -f /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/tmp-core-site
+ echo '</configuration>'
+ CMD=start_scm
+ shift 1
+ case $CMD in
+ moveConfigs
+ for i in '"$HADOOP_CONF_DIR"/*'
++ basename '/var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/empty-hadoop-conf/*'
+ [[ * == hdfs-site.xml ]]
++ basename '/var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/empty-hadoop-conf/*'
+ [[ * == core-site.xml ]]
+ updateCoreSite
+ AUTH_TYPE=simple
+ [[ false == \t\r\u\e ]]
+ perl -pi -e 's/\{\{HTTP_AUTH_TYPE}}/simple/g' /var/run/cloudera-scm-agent/process/1546337746-ozone-STORAGE_CONTAINER_MANAGER/ozone-conf/ozone-site.xml
++ find . -name core-site.xml
++ tail -1
+ FILE=
+ [[ true == \t\r\u\e ]]
+ add_to_site '' hadoop.security.authorization true
+ '[' '!' -f '' ']'
+ echo 'Could not find or is not a file'
+ exit 1

 

Please help give soliution.

 

Thank you

 

Regard,

Doan Gia Hy

1 ACCEPTED SOLUTION

avatar
Reader

Hello. Make sure that hdfs_service is enabled in the Ozone configuration. By having this enabled CM agent will put the core-site.xml into the process directory and that error will be gone. Also, here is a reference to the Ozone dependency on HDFS - https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/hdfs-ozone-migration/topics/hdfs-ozone-de...

View solution in original post

1 REPLY 1

avatar
Reader

Hello. Make sure that hdfs_service is enabled in the Ozone configuration. By having this enabled CM agent will put the core-site.xml into the process directory and that error will be gone. Also, here is a reference to the Ozone dependency on HDFS - https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/hdfs-ozone-migration/topics/hdfs-ozone-de...