Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

Solved Go to solution
Highlighted

Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

Error:

Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

Solution:

The most common reasons for this error are related to using your own custom image. If you are using your own custom image:

- If using the CLI, you must send the image id explicitly in the CLI in the cluster template request

- There was a breaking change between Cloudbreak 2.4 and 2.7 versions. If you burned your image for Cloudbreak 2.4, and you would like to use Cloudbreak 2.7, you must burn a new image.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

@Vinay MP

A couple of questions:

  • are you using your own custom-burnt image?
  • if yes, then do you send the image id explicitly in the CLI in the cluster template request?
  • if yes, then I am afraid that you should burn a new image as there was an incompatible change between 2.4 and 2.7 versions. We will indicate this in the documentation as well.

Hope this helps!

2 REPLIES 2

Re: Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

New Contributor

I faced same problem. I had created cluster template from Cloudbreak 2.4.0.

I used the same template with cloudbreak 2.7.0, cluster creation failed with "Failed to retrieve server certificate" Error.

After referring this thread, I compared the Image ID used in 2.4.0 and 2.7.0 template and found them to be different.

So if there is a problem with the image used to create the instances, it can lead to this error.

Re: Cloudbreak cluster fails with "Infrastructure creation failed. Reason: Failed to retrieve the server's certificate

@Vinay MP

A couple of questions:

  • are you using your own custom-burnt image?
  • if yes, then do you send the image id explicitly in the CLI in the cluster template request?
  • if yes, then I am afraid that you should burn a new image as there was an incompatible change between 2.4 and 2.7 versions. We will indicate this in the documentation as well.

Hope this helps!