Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudera Manager Installation failed with PostgreSQL dependency

Solved Go to solution

Cloudera Manager Installation failed with PostgreSQL dependency

Contributor

Hello,

 

I am trying to deploy a POC cluster using Path A of Cloudera Manager installation documentation. However, it is failing with below message in the logs:

 

cat 5.install-cloudera-manager-server-db-2.log 
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package cloudera-manager-server-db-2.x86_64 0:5.15.1-1.cm5151.p0.3.el7 will be installed
--> Processing Dependency: postgresql-server >= 8.4 for package: cloudera-manager-server-db-2-5.15.1-1.cm5151.p0.3.el7.x86_64
--> Finished Dependency Resolution
Error: Package: cloudera-manager-server-db-2-5.15.1-1.cm5151.p0.3.el7.x86_64 (cloudera-manager)
           Requires: postgresql-server >= 8.4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I also tried to use local repository and point .bin file using --skip_repo_package=1. However,

  1. Was unable to find packages for PostgreSQL 8.4 any where, so created repo of 9.6 instead.
  2. CM at the first place hunts for PostgreSQL 8.4, and then finds 9.6 in the repo, however, fails at dependency check. It still needs few dependent packages (5-6) to proceed.

Before I download each package and put it in repo, seeking suggestions / help from the community on why is the installation with Cloudera repos (installation path A) failing with that message.

 

Thanks

snm1523

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cloudera Manager Installation failed with PostgreSQL dependency

Super Guru

@snm1523,

 

Since you are using install path A, the installation will attempt to install cloudera-manager-server-db-2 which requires postgres server. Note that you need postgres >= 8.4 (not equal to)

 

yum will attempt to download and install a postgres server, but in your case it cannot find any.

 

Can you install posgresql-server manually with "yum?"

 

This thread may have some relevant info too:

https://community.cloudera.com/t5/Cloudera-Manager-Installation/Not-able-to-install-cloudera-manager...

 

 

2 REPLIES 2

Re: Cloudera Manager Installation failed with PostgreSQL dependency

Super Guru

@snm1523,

 

Since you are using install path A, the installation will attempt to install cloudera-manager-server-db-2 which requires postgres server. Note that you need postgres >= 8.4 (not equal to)

 

yum will attempt to download and install a postgres server, but in your case it cannot find any.

 

Can you install posgresql-server manually with "yum?"

 

This thread may have some relevant info too:

https://community.cloudera.com/t5/Cloudera-Manager-Installation/Not-able-to-install-cloudera-manager...

 

 

Highlighted

Re: Cloudera Manager Installation failed with PostgreSQL dependency

Contributor
Hello @bgooley,

Thank you for the guidance. Will attempt the suggested suggestion and come back.

Thanks
snm1523
Don't have an account?
Coming from Hortonworks? Activate your account here