Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-02-2019 07:39 AM - edited 09-16-2022 07:29 AM
Hi,
we have troubles to connect MicroStrategy(=MSTR) to HIVE on HDP3.1 over Knox, when trying to connect we receive:
Unknow failed: Unable to connect.
Error type: System call error. Error communicating with connection process.
Find target process dead while waiting for reply.
We installed ClouderaHiveODBC-2.6.4.1004-1.x86_64.rpm driver.
MSTR Inteligent Server is a RHEL-7.4 machine, installation has been realized according to Cloudera-ODBC-Driver-for-Apache-Hive-Install-Guide.pdf:
yum --nogpgcheck localinstall [RPMFileName]
As we are not sure that yum resolves all dependencies, we install the sasl libraries as well:
cyrus-sasl x86_64 2.1.26-23.el7 rhel-7-server-rpms
odbc.ini looks like:
[hdp.hive.lxprod] Driver=/opt/cloudera/hiveodbc/lib/64/libclouderahiveodbc64.so Host=hdp.lxprod PORT=443 Schema=default ServiceDiscoveryMode=0 HiveServerType=2 AuthMech=3 ThriftTransport=2 HTTPPath=/gateway/DM/hive SSL=1 AllowSelfSignedServerCert=1 CAIssuedCertNamesMismatch=1 TrustedCerts=/etc/pki/tls-ca-bundle.pem
We tested the ODBC-Connection to hdp.lxprod on a Windows machine, with the same driver (ClouderaHiveODBC64.msi, Cloudery ODBC Driver for Apache Hive 2.06.04.1004, Win 64-bit) and it works, so we assume that on HDP-side is everthing ok, and Knox and HIVE is configured well.
We suppose that the problem is located on the MSTR server.
Any ideas?
Thanks in advance
Michael.
Created 07-08-2019 02:07 AM
Hi Eric,
we installed the ClouderaHiveODBC-2.5.25.1020-1.el7.x86_64.rpm driver on the RHEL-Server, and it works!
Seems to be a problem with ClouderaHiveODBC-2.6.4.1004-1.x86_64.rpm driver.
Kind regards,
Michael.
Created 07-04-2019 10:03 PM
Created 07-08-2019 01:35 AM
Hi Erik,
the odbc section looks now like this:
[hdp-hive-lxrls] Driver=/opt/cloudera/hiveodbc/lib/64/libclouderahiveodbc64.so Host=hdprelease.dm-drogeriemarkt.com PORT=443 Schema=default ServiceDiscoveryMode=0 HiveServerType=2 AuthMech=3 ThriftTransport=2 HTTPPath=/gateway/DM/hive SSL=1 AllowSelfSignedServerCert=1 CAIssuedCertNamesMismatch=1 TrustedCerts=/etc/pki/tls-ca-bundle.pem LogPath=/srv/mstr/log/odbcLog/ LogLevel=6
We make sure, that /srv/mstr/log/odbcLog/ is writeable for the process, but no Logfile has been written.
But we found segfault messages in /var/log/messages:
Jul 8 10:03:36 mstr-intranet-01 kernel: M8MulPrc[86769]: segfault at 0 ip 00007feeeccdb016 sp 00007feeda211d58 error 4 in libc-2.17.so[7feeecb9d000+1c2000] Jul 8 10:03:50 mstr-intranet-01 kernel: M8MulPrc[86808]: segfault at 0 ip 00007f7de2325016 sp 00007f7dcf85bd58 error 4 in libc-2.17.so[7f7de21e7000+1c2000] Jul 8 10:05:41 mstr-intranet-01 kernel: M8MulPrc[87501]: segfault at 0 ip 00007f2772bb1016 sp 00007f27600e7d58 error 4 in libc-2.17.so[7f2772a73000+1c2000] Jul 8 10:05:55 mstr-intranet-01 kernel: M8MulPrc[87535]: segfault at 0 ip 00007f1a5f2b0016 sp 00007f1a4c7e6d58 error 4 in libc-2.17.so[7f1a5f172000+1c2000] Jul 8 10:09:41 mstr-intranet-01 kernel: M8MulPrc[88893]: segfault at 0 ip 00007ff50653b016 sp 00007ff4f3a71d58 error 4 in libc-2.17.so[7ff5063fd000+1c2000] Jul 8 10:09:55 mstr-intranet-01 kernel: M8MulPrc[88926]: segfault at 0 ip 00007fb919338016 sp 00007fb90686ed58 error 4 in libc-2.17.so[7fb9191fa000+1c2000]
uname -r : 3.10.0-862.14.4.el7.x86_64
cat /etc/redhat-release : Red Hat Enterprise Linux Server release 7.6 (Maipo)
I will try to install an older Cloudera Driver 2.5.x, and see what happens.
Regards,
Michael.
Created 07-08-2019 02:07 AM
Hi Eric,
we installed the ClouderaHiveODBC-2.5.25.1020-1.el7.x86_64.rpm driver on the RHEL-Server, and it works!
Seems to be a problem with ClouderaHiveODBC-2.6.4.1004-1.x86_64.rpm driver.
Kind regards,
Michael.
Created 07-11-2019 05:36 PM
Created 07-18-2019 01:23 AM
Hi Eric,
I think the "C6 Compatibility" can be excluded because the driver for Windows works in conjunction with the same HDP cluster. Probably a problem with the implementation of the driver for Linux or RedHat.
I will not further investigate and will mark this post as solved.
Regards,
Michael.