Support Questions
Find answers, ask questions, and share your expertise

Connection refused for HDF sandbox

I have been able to connect to HDP sanbox by ssh -p 2222. But with the new HDF sandbox, I was stuck again with the "connection refused" error. After I brought up the sandbox, I tried the URL "http://10.0.2.15:18888/" but just got timeout error. Any idea ? @mqureshi

1 ACCEPTED SOLUTION

Accepted Solutions

Finally I figured out the reason. I downloaded the HDF sandbox vmware image. When I click the file to open, it pop up and automatically opened by virtualbox which can't work correctly for the network part. Realized this, I turned off and opened in VMWare. Issue gone. Thanks for your help.

View solution in original post

15 REPLIES 15

Guru

@Lucy zhang

Is your VM setup to use NAT? I've got the HDF Sandbox running right now, and have a 127.0.0.1 IP.

Yes, the VM setup is using NAT, After I started the VM. Before press ALT+F5, The VMware says "please open a browser's address field: http://10.0.2.15:18888/. However I got "connection time out " error. I press ALT+F5 to log in the Vmware as root user. Then tried "ssh -p 2222 root@127.0.0.1" it doesn't work. @Sonu Sahi Could you help check if you did the same but got different result ? Thanks

Guru

Hi @Lucy zhang

I'm using VirtualBox, but, I think the NAT setup is all that is required. I did not do anything special for my setup. Using the VirtualBox menu, I imported the appliance which automatically setup the NAT configuration. When the machine finished installing, I started the machine and saw this screen:

15576-screen-shot-2017-05-19-at-114806-am.png

One thine to note is the ports on the HDF Sandbox are different compared to the HDP Sandbox. While 2222 was correct for SSH'ing into the HDP Sandbox, HDF Sandbox actually uses 12222. I use the following command to SSH into the HDF Sandbox: ssh root@127.0.0.1 -p 12222

Thank you @Sonu Sahi for your response. I'm actually also using virtual box. Attached is my screenshot: NOt sure what's wrong. My network configuration also NAT.


virtualbox-config.pngfirst-screen.jpg

Finally I figured out the reason. I downloaded the HDF sandbox vmware image. When I click the file to open, it pop up and automatically opened by virtualbox which can't work correctly for the network part. Realized this, I turned off and opened in VMWare. Issue gone. Thanks for your help.

View solution in original post

Guru

Awesome, glad you are back up and running 🙂

Hi @Sonu Sahi . Any idea with below error? I tried this script in both virtualBox and Vmware. Neither works.

In VirtualBox, it complains vboxmanage not found.

Thanks

[root@sandbox-hdf ~]# ./auto_scripts/launch_ambari_ui.sh HDF

Sandbox Virtual Environment Selection Menu

'Docker' - is my environment

'VirtualBox' - is my environment

Enter the 'virtual environment' for HDF Sandbox: VirtualBox

You entered HDF Sandbox runs on: VirtualBox Start VirtualBox VM's Docker HDF Sandbox... ./auto_scripts/virtualbox-scripts/virtualbox_sandbox_hdf.sh: line 3: vboxmanage: command not found Starting Ambari Services, may take 2.5 minutes...

New Contributor

@Lucy zhang

Did you ever resolve this issue? I am having the same problem as you in Docker. Port 18888 works fine, but Nifi UI and the other ports are getting connection refused.

Guru

Can you get to the main welcome page? http://127.0.0.1:18888 or try also http://127.0.0.1:9080