Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Connection to localhost:5432 refused on nifi UI

avatar
Contributor

Hello. Im currently running nifi and postgresql on docker compose. I have a problem setting up the DBCPConnectionPool controller. I keep getting the error message below.

 

화면 캡처 2022-07-13 131449.png

Below is my configuration for DBCPConnectionPool 

화면 캡처 2022-07-13 131603.png

I have checked the db name and docker compose yml file but nothing seems wrong on that end. What could be causing the problem here? 

1 ACCEPTED SOLUTION

avatar
Contributor

Ok just in case anyone is suffering from the same problem as me.

Since I am running this on docker compose,

instead of localhost:5432, I changed it to <container name>:5432 and its working now 

View solution in original post

1 REPLY 1

avatar
Contributor

Ok just in case anyone is suffering from the same problem as me.

Since I am running this on docker compose,

instead of localhost:5432, I changed it to <container name>:5432 and its working now