Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
02-10-2023
09:56 AM
- last edited on
04-21-2026
12:44 AM
by
GrazittiAPI
I've installed and configured MIT Kerberos for Windows Hive ODBC connection.
I could not create Kerberos ticket for more than one user, the new ticket created overwrites the existing ticket. Hence multiple user accessing that Windows machine could not obtain a valid ticket to connect to Hive ODBC connections.
I've set krbs.conf from the Hive server and KRB5CCNAME is set to C:\temp\krb5cache.
Please let me know how to configure this to have more valid tickets for each user.
Created 02-22-2023 12:12 PM
Hi. Yeah its expected when you have the common path for tgt cache for multiple user. Can you make the location unique for each different user - I haven't tested but I see an option in this link https://gpdb.docs.pivotal.io/6-3/admin_guide/kerberos-win-client.html
Set up the Kerberos credential cache file. On the Windows system, set the environment variable KRB5CCNAME to specify the file system location of the cache file. The file must be named krb5cache. This location identifies a file, not a directory, and should be unique to each login on the server. When you set KRB5CCNAME, you can specify the value in either a local user environment or within a session. For example, the following command sets KRB5CCNAME in the session:
set KRB5CCNAME=%USERPROFILE%\krb5cache
Created 02-27-2023 09:16 AM
@pauljoshiva Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks
Regards,
Diana Torres,