Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
10-30-2019
10:28 AM
- last edited on
10-30-2019
10:50 AM
by
lwang
Hello everyone,
I have a question about enabling the TLS communication between the hosts in my cluster.
The installation procedure recommends to enable the TLS over the cluster, but when I try to run the following command:
sudo JAVA_HOME=/usr/java/jdk1.8.0_181-cloudera /opt/cloudera/cm-agent/bin/certmanager setup --configure-services
I receive the following errors:
The first warning is:
could not generate CSR
When I check the log I got two errors:
req failed for /var/lib/cloudera-scm-server/certmanager/CMCA/private/ca_key.pem. Exit code: 1 Output:
problems making Certificate Request
139727014807440:error:0D07A097:asn1 encoding routines:ASN1_mbstring_ncopy:string too long:a_mbstr.c:158:maxsize=64
Does anyone have the same problem? I am struggling to figure out this issue and after having googled it I have not found much...
If I skip this step, unfortunately, I will not be able to pass the Inspect Network Performance.
I already tried to skip this step, but when I was ending the installation, the file "cert.py" is used to test the connection between the nodes, and it wouldn't work (I already tried) giving me the error: unable to reach the hosts".
Any case, I am able to connect through ssh command from the master to the other nodes, here an example:
Thanks,
M
Created 10-30-2019 12:24 PM
Hi @m4x1m1li4n ,
The error message below seems to indicate some data for generating the certificate is exceeding the 64 characters limit.
139727014807440:error:0D07A097:asn1 encoding routines:ASN1_mbstring_ncopy:string too long:a_mbstr.c:158:maxsize=64
CN in a certificate may not exceed 64 characters. I wonder if your host name is too long which make it exceed the limit of 64 characters?
Thanks,
Li
Li Wang, Technical Solution Manager
Created 10-30-2019 12:24 PM
Hi @m4x1m1li4n ,
The error message below seems to indicate some data for generating the certificate is exceeding the 64 characters limit.
139727014807440:error:0D07A097:asn1 encoding routines:ASN1_mbstring_ncopy:string too long:a_mbstr.c:158:maxsize=64
CN in a certificate may not exceed 64 characters. I wonder if your host name is too long which make it exceed the limit of 64 characters?
Thanks,
Li
Li Wang, Technical Solution Manager
Created 10-31-2019 02:16 AM
Hi Li,
first, thank you so much for your answer! Very appreciated!
Good spot! I registered a subdomain in my Amazon VPC and the etc/host looks like this:
Therefore, my hostname for the master is the following:
However, when I re-run the following command:
sudo JAVA_HOME=/usr/java/jdk1.8.0_181-cloudera /opt/cloudera/cm-agent/bin/certmanager --location /opt/cloudera/CMCA setup --configure-servicesI receive the following:
I guess I should remove the key generated and re-do the command.
Do you know how can I do that?
Many thanks,
M
Created 11-01-2019 11:02 AM
Hi @m4x1m1li4n ,
Looks like you used custom location. You may want to take a look at the location:
/opt/cloudera/CMCA
and see if there are some data inside. Try to move those files to different location and see if that helps.
Thanks,
Li
Li Wang, Technical Solution Manager