Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Data Provenance not showing on imported template

Solved Go to solution
Highlighted

Data Provenance not showing on imported template

Explorer

Hi, currently  I have 2 process groups on NiFi 1.11.3, the native one is showing data provenance on every processor as it should.

The imported template (from 1.9.2) inside another group shows a blank provenance window.

Any idea of what can be causing this?

Thank you!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Data Provenance not showing on imported template

Master Guru

@Alexandros 

 

Going to ask the simple question first... There are FlowFiles traversing the processors in this newly instantiated flow from your template, correct?

--- The next thought would then be around authorizations (assuming your NiFi is secured) 

1. Is your user running the provenance query authorized to "view provenance" and "view the data" on the components?  If these are set on the process group containing these processor components and not set on the components themselves, the components will inherit the polices from the process group.

2. Is this a NiFi cluster?  If so, make sure your NiFi nodes are also authorized to "view provenance" and "view the data".  When you authenticate in to NiFi and run a provenance query, that query is replicated to all nodes in your cluster.  Those query results are then returned to the node on which the originating request was made.  If that node is not authorized to view data returned from other nodes, it will not display.

 

--- Then we need to make sure provenance it still working:


While you are seeing provenance events displayed for your existing flow, are those returns recent?  If you monitor the contents of your provenance_repository, do you see timestamps updating on the <num>.prov files?  Need to make sure provenance has not stopped working for some reason.  Also make sure you are using the WriteAheadProvenanceRepository implementation (should be default in 1.11) and not the PersistentProvenanceRepository implementation (configured in nifi.properties file).

 

Hope this helps,

Matt

View solution in original post

3 REPLIES 3
Highlighted

Re: Data Provenance not showing on imported template

Explorer

Sorry for the bump, have more time than usual to solve this kind of problems, any idea?

It's becoming hard to debug flows without this.

Thank you!

Re: Data Provenance not showing on imported template

Master Guru

@Alexandros 

 

Going to ask the simple question first... There are FlowFiles traversing the processors in this newly instantiated flow from your template, correct?

--- The next thought would then be around authorizations (assuming your NiFi is secured) 

1. Is your user running the provenance query authorized to "view provenance" and "view the data" on the components?  If these are set on the process group containing these processor components and not set on the components themselves, the components will inherit the polices from the process group.

2. Is this a NiFi cluster?  If so, make sure your NiFi nodes are also authorized to "view provenance" and "view the data".  When you authenticate in to NiFi and run a provenance query, that query is replicated to all nodes in your cluster.  Those query results are then returned to the node on which the originating request was made.  If that node is not authorized to view data returned from other nodes, it will not display.

 

--- Then we need to make sure provenance it still working:


While you are seeing provenance events displayed for your existing flow, are those returns recent?  If you monitor the contents of your provenance_repository, do you see timestamps updating on the <num>.prov files?  Need to make sure provenance has not stopped working for some reason.  Also make sure you are using the WriteAheadProvenanceRepository implementation (should be default in 1.11) and not the PersistentProvenanceRepository implementation (configured in nifi.properties file).

 

Hope this helps,

Matt

View solution in original post

Highlighted

Re: Data Provenance not showing on imported template

Explorer

Ok, this is all me for not understanding permissions correctly, I thought that if a permission wasn't configured it heredates the the permissions of NiFi.

So: I'm Admin, I generated a group I should have access.

You made me check again and I thank you for that!

 

 

Don't have an account?
Coming from Hortonworks? Activate your account here