Support Questions
Find answers, ask questions, and share your expertise

Dependency Issue when running "yum install ambari-server"

Solved Go to solution

Dependency Issue when running "yum install ambari-server"

Explorer

Whenever I try to install ambari-server on CenTOS 6.6, I get stuck at the dependency checking part.

It simply tells me that there is an error in dependencies :

ambari-server-1.7.0-169.noarch requires postgresql-server

I looked up the documentation and can't find a way to solve this, which is weird since ambari-server should install postgre. Shouldn't be a problem on the repo either.

Any way to solve this ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Dependency Issue when running "yum install ambari-server"

@Nicolas YUE

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/ch_Installing_...

You should use Ambari 2.2

Also, you do need postgres install...its failing on postgres - Dependcy check

View solution in original post

7 REPLIES 7

Re: Dependency Issue when running "yum install ambari-server"

@Nicolas YUE

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_Installing_HDP_AMB/content/ch_Installing_...

You should use Ambari 2.2

Also, you do need postgres install...its failing on postgres - Dependcy check

View solution in original post

Re: Dependency Issue when running "yum install ambari-server"

Explorer

I just tried something else, actually, whichever version of Ambari I use, it'll ask for a 8.1 postgre dependency. Problem is that postgre 8.1 is for CenTOS 5 and I'm on CentOS 6.

Any idea for this ?

Re: Dependency Issue when running "yum install ambari-server"

@Nicolas YUE

You can install your own postgres. Ambari will be happy to see your version of postgres.

http://www.postgresql.org/download/linux/redhat/

Re: Dependency Issue when running "yum install ambari-server"

Explorer

It worked !

I downloaded the postgre's rpm for my version of CenTOS, and once installed, I could run yum install ambari-server with no problem on dependencies anymore.

Re: Dependency Issue when running "yum install ambari-server"

Can you install the package without dependencies, e.g. by using the yum-option --nodeps (http://yum.baseurl.org/wiki/NoDeps)

Re: Dependency Issue when running "yum install ambari-server"

Mentor
@Nicolas YUE

please check your repos. I had this happen to me when I had some posters libraries already. Remove repos, yum clean all. Rpm -qa | grep Ambari and then grep postgres. Yum erase Ambari postgres and then try with latest Ambari. For Ambari 2.2 make sure your HDP version is at least 2.2

Re: Dependency Issue when running "yum install ambari-server"

Explorer

I simply installed postgresql 8.4 and now there are no issues anymore, just like Neeraj said.

I haven't tried the other solutions yet since it was the simplest way but thank you all !