Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Directory read permission setting does not work

Solved Go to solution

Directory read permission setting does not work

Contributor

I use chmod to give others the read permission on the home/maria_dev directory. However, the user hive still cannot read the directory.

[maria_dev@sandbox-hdp ~]$ ls -ld
drwx---r-- 1 maria_dev maria_dev 4096 Mar  5 05:35 .
[maria_dev@sandbox-hdp ~]$ sudo su hive
[hive@sandbox-hdp maria_dev]$ ls
ls: cannot open directory .: Permission denied


1 ACCEPTED SOLUTION

Accepted Solutions

Re: Directory read permission setting does not work

Contributor

You must provide read and execute (r-x) permissions to others.


Try this

$ chmod 705 /home/maria_dev
$ sudo su hive

$ ls -l /home/maria_dev
4 REPLIES 4

Re: Directory read permission setting does not work

Mentor

@Haijin Li

I think there is a problem with your command the - (hyphen) is missing can you copy and paste the below

$ sudo su - hive 

Please revert

Re: Directory read permission setting does not work

Contributor

@Geoffrey Shelton Okot

My intention is to use "su hive", not "su - hive".

Below is the resource showing the difference.

https://www.tecmint.com/difference-between-su-and-su-commands-in-linux/

Thanks.

Re: Directory read permission setting does not work

Contributor

You must provide read and execute (r-x) permissions to others.


Try this

$ chmod 705 /home/maria_dev
$ sudo su hive

$ ls -l /home/maria_dev

Re: Directory read permission setting does not work

Contributor

@Gulshad Ansari

Thanks. You are right. The execute permission is required for entering the directory.