Support Questions
Find answers, ask questions, and share your expertise

Does not start HUE_SERVER

Solved Go to solution

Does not start HUE_SERVER

Explorer

I'm using CDH-6.2.0. and hue.

 

HUE_LOAD_BALANCER is run fine.

But HUE_SERVER does not run on each node(2 node).

I've looked at the logs, but I can't find any problems. The strange thing is that even if you run the server once, it looks like it is running 4 times in the runcpserver.log as shown in the figure below, and in the supervisor log, you can see a log saying that it was executed too many times. 

That's my own log file.

supervisord.log

 

 

2021-03-30 16:37:03,391 INFO spawned: '178-hue-HUE_SERVER' with pid 24378
2021-03-30 16:37:12,722 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:13,726 INFO spawned: '178-hue-HUE_SERVER' with pid 24586
2021-03-30 16:37:22,823 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:24,829 INFO spawned: '178-hue-HUE_SERVER' with pid 24857
2021-03-30 16:37:33,645 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:36,653 INFO spawned: '178-hue-HUE_SERVER' with pid 25067
2021-03-30 16:37:45,512 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:46,174 INFO gave up: 178-hue-HUE_SERVER entered FATAL state, too many start retries too quickly

 

 

runcpserver.log

 

 

[30/Mar/2021 16:37:11 ] settings INFO Welcome to Hue 4.3.0
[30/Mar/2021 16:37:21 ] settings INFO Welcome to Hue 4.3.0
[30/Mar/2021 16:37:32 ] settings INFO Welcome to Hue 4.3.0
[30/Mar/2021 16:37:44 ] settings INFO Welcome to Hue 4.3.0

 

 

 

When i started in Cloudera Manager. CM print  that "Supervisor returned FATAL. Please check the role log file, stderr, or stdout."

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Does not start HUE_SERVER

Cloudera Employee

Hey, @meenzoon Hope this message finds you.

I did get a chance to review your logs:

1. Was there a recent upgrade from CDH5 to CDH6?

2. Are there any other roles in this instance not working?

2021-03-30 16:37:45,512 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:46,174 INFO gave up: 178-hue-HUE_SERVER entered FATAL state, too many start retries too quickly

The above indicates there seems to be an issue with Supervisord. However,

3. What do you observe in the Hue role's stderr and stdout?

Hint: You can get the Hue Process's stderr and stdout under

CM > Hue > Instances > Hue Server > Log Files > Stdout and Stderr(Quick-link)

 

Let us know how it goes.

View solution in original post

3 REPLIES 3

Re: Does not start HUE_SERVER

Cloudera Employee

Hey, @meenzoon Hope this message finds you.

I did get a chance to review your logs:

1. Was there a recent upgrade from CDH5 to CDH6?

2. Are there any other roles in this instance not working?

2021-03-30 16:37:45,512 INFO exited: 178-hue-HUE_SERVER (exit status 0; not expected)
2021-03-30 16:37:46,174 INFO gave up: 178-hue-HUE_SERVER entered FATAL state, too many start retries too quickly

The above indicates there seems to be an issue with Supervisord. However,

3. What do you observe in the Hue role's stderr and stdout?

Hint: You can get the Hue Process's stderr and stdout under

CM > Hue > Instances > Hue Server > Log Files > Stdout and Stderr(Quick-link)

 

Let us know how it goes.

View solution in original post

Re: Does not start HUE_SERVER

Explorer

Hey @vaishaakb thanks for your reply.

 

I wasn't changed the CDH version. But i tested to change the path of the '/var/lib' folder location. Like a 'sevice-monitor', 'host-monitor'. And i current location recovery to '/var/lib'.

In this host another roles started healthy.

I check again stderr, stdout and i found a "altscript.sh" this file causing the problem. That problem is a not found a "creds.localjceks" file. So changed "/opt/~~~~/altscript.sh" the file. 

And i solved this problem.

 

Thanks again for your reply.

 

Re: Does not start HUE_SERVER

Cloudera Employee

Hello @meenzoon,

I am glad to hear that this situation is resolved and really appreciate you providing the steps you took to solve this.

Have a good one!