Support Questions
Find answers, ask questions, and share your expertise

ERROR: Unexpected error Ambari repo file path not set for current OS.

Hi,

I am using Linux-Mint. I am getting the following error when I try to setup ambari server.

Can you please help me?

Thanks in advance.

sboxes@osboxes ~ $ sudo ambari-server setup

Using python /usr/bin/python

Setup ambari-server

Checking SELinux...

WARNING: Could not run /usr/sbin/sestatus: OK

Customize user account for ambari-server daemon [y/n] (n)?

ERROR: Unexpected error Ambari repo file path not set for current OS.

ERROR: Exiting with exit code 1. REASON: Failed to create user. Exiting.

osboxes@osboxes ~ $

1 ACCEPTED SOLUTION

Accepted Solutions

Contributor

Hi @Subrahmanya Oruganti

I don't believe that Linux Mint is a supported distribution for HDP or HDF. I think the closest would be Ubuntu 16.04.

Please see the HDP install guide.

View solution in original post

6 REPLIES 6

Contributor

Hi @Subrahmanya Oruganti

I don't believe that Linux Mint is a supported distribution for HDP or HDF. I think the closest would be Ubuntu 16.04.

Please see the HDP install guide.

View solution in original post

Thank you Brosander

Contributor

Is Elementary OS supported ?? it uses internally Ubuntu 16.04

Super Mentor

@Subrahmanya Oruganti'

Please find the Supported Operating System Details:

http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_support-matrices/content/ch_matrices-amba...

- I am afraid that Linux-Mint is not in the Tested/Supported Operating Systems list. Hence ambari is not able to locate the Repository for this Operating system and hence it is failing.

Please take a look at: https://github.com/apache/ambari/blob/release-2.5.0/ambari-common/src/main/python/ambari_commons/os_...

Thank you Jay.

Contributor

Is Elementary OS supported ?? it uses internally Ubuntu 16.04