Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

ERROR View Zeppelin Ambari

Solved Go to solution

ERROR View Zeppelin Ambari

Super Collaborator

hi:

Any Reason why i can see zeppelin view from ambari?, here the error:

HTTP ERROR 500
Problem accessing /views/ZEPPELIN/1.0.0/ZEPPELIN/. Reason:
    Server Error
Caused by:
org.apache.jasper.JasperException: PWC6033: Unable to compile class for JSP

PWC6199: Generated servlet error:
The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files


	at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:123)
	at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:296)
	at org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:376)
	at org.apache.jasper.compiler.Compiler.compile(Compiler.java:437)
	at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:608)
	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:360)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:486)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:380)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:575)
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:427)
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
	at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:276)
	at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:103)
	at org.apache.ambari.view.zeppelin.ZeppelinServlet.doGet(ZeppelinServlet.java:68)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:687)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: ERROR View Zeppelin Ambari

@Frederic Guiet & @Roberto Sancho

It is related to JIRA: https://issues.apache.org/jira/browse/AMBARI-18918 (Zeppelin view doesn't work with JDK 1.8_91+)

Which will be addressed in Ambari 2.5

7 REPLIES 7

Re: ERROR View Zeppelin Ambari

New Contributor

Can you please provide little more details. like what version of Ambari,HDP ? any screenshot that constitute the error?

Re: ERROR View Zeppelin Ambari

Super Collaborator

Hi: the HDP Version is 2.5.0.0 .

8680-snip20161019-2.png

The error is:

HTTP ERROR 500
Problem accessing /views/ZEPPELIN/1.0.0/ZEPPELIN/. Reason:
    Server Error
Caused by:
org.apache.jasper.JasperException: PWC6033: Unable to compile class for JSP

PWC6199: Generated servlet error:
The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files


 at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:123)
 at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:296)
 at org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:376)
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java:437)
 at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:608)
 at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:360)
 at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:486)
 at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:380)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
 at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
 at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
 at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
 at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:575)
 at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
 at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
 at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:427)
 at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
 at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)

Re: ERROR View Zeppelin Ambari

New Contributor
down vote

I had the same problem using Java 8 but using Java 7 works fine.

java -jar jackrabbit-standalone-2.11.3.jar
Highlighted

Re: ERROR View Zeppelin Ambari

Super Collaborator

Hi:

So what do you recommend me?, set JAVA_HOME to version 7 and restar the component¿

Thanks

Re: ERROR View Zeppelin Ambari

New Contributor

I have got the same problem here.

Ambari Version 2.4.0.1

HDP 2.5

Java JDK 1.8.0_92

How can I solve this problem ?

Thanks

,

I've got the same problem : HDP 2.5, JDK 1.8.0_92, Ambari Version 2.4.0.1

Can anyone help to solve this problem ?

Re: ERROR View Zeppelin Ambari

@Frederic Guiet & @Roberto Sancho

It is related to JIRA: https://issues.apache.org/jira/browse/AMBARI-18918 (Zeppelin view doesn't work with JDK 1.8_91+)

Which will be addressed in Ambari 2.5

Re: ERROR View Zeppelin Ambari

New Contributor

@jss

Awesome! Thank you for sharing the info!

Don't have an account?
Coming from Hortonworks? Activate your account here