Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Enable LDAP Authentication on Hive caused HUE to not load a databases

SOLVED Go to solution

Enable LDAP Authentication on Hive caused HUE to not load a databases

New Contributor

Hi,

 

   I'm using CDH 5.12 with 16 nodes. Our setup is LDAP for HUE via Sentry. Everything works as expected. We can create user on LDAP and grant a permisson with Sentry. However, I'm also want to apply same login to the beeline. But when "Enable LDAP Authentication" on Hive Configuration, It caused error on HUE with message "Bad status: 3 (Error validating the login)" and no databases list loading.

 

   Thank you very much for any clue or help.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Enable LDAP Authentication on Hive caused HUE to not load a databases

New Contributor

Yes. I've end-up using impersonate user following this article http://gethue.com/ldap-or-pam-pass-through-authentication-with-hive-or-impala/ 

 

and plus

 

<property>
<name>hadoop.proxyuser.hue_hive.groups</name>
<value>*</value>
</property>

 

on core-site.xml by this answer http://community.cloudera.com/t5/Web-UI-Hue-Beeswax/Failed-to-validate-proxy-privilege-of-hue-hive-f...

4 REPLIES 4
Highlighted

Re: Enable LDAP Authentication on Hive caused HUE to not load a databases

Expert Contributor

I suppose you have also configured Kerberos on your cluster.

From Cloudera Manager, go to HUE configuration.

Search the "Hue Server Advanced Configuration Snippet (Safety Valve) for hive-site.xml" and add the following property.

Name: hive.server2.authentication

Value: kerberos

 

or if you use xml view:

<property>
  <name>hive.server2.authentication</name>
  <value>kerberos</value>
<final>true</final> </property>

Re: Enable LDAP Authentication on Hive caused HUE to not load a databases

Expert Contributor

Just to give some more info.

When you enable LDAP authentication for Hive, HUE gets confused and tries also to connect to Hive via LDAP, instead of Kerberos authentication. By setting this configuration, you force HUE to go with Kerberos authentication while your Hive can still accept both.

Re: Enable LDAP Authentication on Hive caused HUE to not load a databases

Expert Contributor

Have you tried this configuration?

Re: Enable LDAP Authentication on Hive caused HUE to not load a databases

New Contributor

Yes. I've end-up using impersonate user following this article http://gethue.com/ldap-or-pam-pass-through-authentication-with-hive-or-impala/ 

 

and plus

 

<property>
<name>hadoop.proxyuser.hue_hive.groups</name>
<value>*</value>
</property>

 

on core-site.xml by this answer http://community.cloudera.com/t5/Web-UI-Hue-Beeswax/Failed-to-validate-proxy-privilege-of-hue-hive-f...