Support Questions
Find answers, ask questions, and share your expertise

Entity schedule failed for PROCESS: MirrorTest

Solved Go to solution
Highlighted

Entity schedule failed for PROCESS: MirrorTest

I try to run the Mirror job but I face this error :

Entity schedule failed for PROCESS: MirrorTest

I saw in another thread that it concern permission (https://community.hortonworks.com/questions/7942/problem-while-mirroring-dataset-between-hadoop-clu.html) but after I gave 777 permission to the workflow.xml I still face the same error.

drwxrwxrwx - falcon users 0 2016-02-09 15:06 /apps/data-mirroring/workflows

-rwxrwxrwx 3 falcon users 5010 2016-02-09 15:06 /apps/data-mirroring/workflows/hdfs-replication-workflow.xml

Is there something I am missing ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Entity schedule failed for PROCESS: MirrorTest

Explorer

you did right by setting the permission to 777 for /apps/data-mirroring/workflows/* but apart from that when you create the MirrorTest, a directory in the name of MirrorTest gets created at this location where the workflow of MirrorTest i.e.workflow.xml gets generated at location /apps/falcon/backupCluster/staging/falcon/workflows/process/MirrorTest .Same applies for primaryCluster also.. Now make sure that the path from staging/falcon/workflows/process/MirrorTest should be set as 777/755 so that the workflow.xml has permissions 777 & ownership=ambari-qa

View solution in original post

1 REPLY 1

Re: Entity schedule failed for PROCESS: MirrorTest

Explorer

you did right by setting the permission to 777 for /apps/data-mirroring/workflows/* but apart from that when you create the MirrorTest, a directory in the name of MirrorTest gets created at this location where the workflow of MirrorTest i.e.workflow.xml gets generated at location /apps/falcon/backupCluster/staging/falcon/workflows/process/MirrorTest .Same applies for primaryCluster also.. Now make sure that the path from staging/falcon/workflows/process/MirrorTest should be set as 777/755 so that the workflow.xml has permissions 777 & ownership=ambari-qa

View solution in original post